Note: This bug is displayed in read-only format because
the product is no longer active in Red Hat Bugzilla.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
DescriptionTimothy Williams
2014-06-25 15:25:18 UTC
Description of problem:
Attempting to remove an image, an error message is reported stating that a container is using the image. All containers are stopped:
$ docker rmi fbe51255ac15
Error: Conflict, cannot delete fbe51255ac15 because the container a0a8d8de4744 is using it, use -f to force
$ docker rm a0a8d8de4744
a0a8d8de4744
After removing each container the error message reports, the image still cannot be removed, reporting the following error stating the image id cannot be found:
$ docker rmi fbe51255ac15
Error: No such id: b8c287cf50a1151c53d1b7e6102661b01a54e61c52cd491a70476d242e92ac57
However, the image is still seen in the `docker images` output:
$ docker images | grep fbe51255ac15
<none> <none> fbe51255ac15 2 days ago 469.3 MB
It is difficult to reproduce the issue consistently. The issue has been reported on the dotcloud github issue tracker. It appears this may have already been resolved upstream:
https://github.com/dotcloud/docker/issues/3258https://github.com/dotcloud/docker/issues/4025
Version-Release number of selected component (if applicable):
$ docker version
Client version: 0.11.1-dev
Client API version: 1.12
Go version (client): go1.2.1
Git commit (client): 02d20af/0.11.1
Server version: 0.11.1-dev
Server API version: 1.12
Go version (server): go1.2.1
Git commit (server): 02d20af/0.11.1
How reproducible:
Sometimes
Steps to Reproduce:
1. Build or create multiple images
2. Attempt to remove the images, removing all dependent cartridges
3.
Actual results:
Still unable to delete image after all dependent cartridges are removed:
$ docker rmi fbe51255ac15
Error: No such id: b8c287cf50a1151c53d1b7e6102661b01a54e61c52cd491a70476d242e92ac57
Expected results:
Image removed
Additional info:
This issue has been resolved in numerous ways, such as removing all containers or stopping all running containers.
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.
For information on the advisory, and where to find the updated
files, follow the link below.
If the solution does not work for you, open a new bug report.
http://rhn.redhat.com/errata/RHBA-2014-1266.html