Bug 111336 - FC1 fails to install with LVM
FC1 fails to install with LVM
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-02 06:37 EST by djh
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-22 01:40:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description djh 2003-12-02 06:37:41 EST
Description of problem:
Anaconda fails to mkfs the root partition.  The following error dialog 
pops up:

"An error occurred trying to format Volume00/LogVol00.  This problem 
is serious, and the install cannot continue..."

The following error is on vt5:
"mke2fs: No such device or address while trying to determine 
filesystem size."



How reproducible:
100% (with GUI and VNC installs)



Additional info:
The system is a crappy old P233, 64M, currently only 1x 9G harddrive.

The partition layout is:
/dev/hda1 /boot 100M
/dev/hda2 swap 128M
/dev/hda3 LVM ~8G
(I've tried various LV configurations - all fail)

FC1 will install on this system if I don't use LVM.
I've tried the same config with the RH9 installer - it works okay.
Comment 1 Jeremy Katz 2003-12-02 12:28:26 EST
Can you switch to tty2 and check if the device node exists?  If so,
can you run mke2fs by hand and see if it fails?
Comment 2 djh 2003-12-02 21:13:33 EST
The device nodes are there, and mke2fs works.

The device name in the error dialog doesn't have the "/dev/" prefix - 
should it?
Comment 3 djh 2003-12-02 22:16:31 EST
Here's some more info..

- The installer got up to where it's about to start installing packages.
- I switched to vt2 and successfully ran mke2fs on all three LVs.
- I then clicked to continue the installation process, and it failed
to mke2fs on LogVol01.
- I switched back to vt2 and now mke2fs fails on all three LVs (No
such file or address).

The VG is now unavailable.  By running vgchange -ay Volume00 on vt2, I 
can mke2fs again.

The first line in /tmp/lvmout is about Volume00 being successfully 
deactivated.  There's no mention of it being re-activated.
Comment 4 djh 2004-03-22 01:40:24 EST
Just FYI, the only way I could get it to work was to do a fresh RH9
install with LVM, then upgrade it to FC1.

Closing.

Note You need to log in before you can comment on or make changes to this bug.