Bug 111339 - kernel oops when syncing palm pda via usb
Summary: kernel oops when syncing palm pda via usb
Status: CLOSED DUPLICATE of bug 107929
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 1
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-12-02 12:06 UTC by Ivo
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:00:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output (2.71 KB, text/plain)
2003-12-02 12:07 UTC, Ivo
no flags Details

Description Ivo 2003-12-02 12:06:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20030701

Description of problem:
kernel oopses in usb_disconnect when syncing with my palm tungsten via
usb (using the visor module). 
A way to reproduce the oops reliably is to initiate a sync and then
cancel the connection from the palm. In normal operation the sync
often succeeds but produces an oops occasionally, say 1 in 4 times.

I've observed this both on my laptop using the 2.4.22-1.2115.nptl
kernel, as well as my dual processor desktop machine under
2.4.22-1.2129.nptlsmp. I'll add an attachment with relevant dmesg output.



Version-Release number of selected component (if applicable):
kernel-2.4.22-1.2129.nptl

How reproducible:
Sometimes

Steps to Reproduce:
1. sync palm using pilot-xfer, jpilot, or gnome-pilot-applet
2. cancel the connection on the pda
3.
    

Actual Results:  program doing the sync, e.g. jpilot, hangs in disk
wait. dmesg report kernel oops. usb moules cannot be unloaded.

Expected Results:  no kernel oops. sync should be canceled.

Additional info:

Comment 1 Ivo 2003-12-02 12:07:15 UTC
Created attachment 96279 [details]
dmesg output

Comment 2 Ivo 2003-12-04 11:39:41 UTC

*** This bug has been marked as a duplicate of 107929 ***

Comment 3 Red Hat Bugzilla 2006-02-21 19:00:15 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.