Bug 111363 - rpm-build should Requires: elfutils
Summary: rpm-build should Requires: elfutils
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm-build (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-12-02 16:41 UTC by Maxim Dziumanenko
Modified: 2007-04-18 16:59 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-05 14:03:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Maxim Dziumanenko 2003-12-02 16:41:39 UTC
Description of problem:
/usr/lib/rpm/find-debuginfo.sh (from rpm-build package) uses eu-strip
(belongs to elfutils package), thus rpm-build should Requires: elfutils

Version-Release number of selected component (if applicable):
rpm-4.2.1-0.30.1.src.rpm 

How reproducible:
Always

Steps to Reproduce:
1.rpm -i rpm-build-4.2.1-0.30.1.i386.rpm
redhat-rpm-config-8.0.28-1.1.i386.rpm
2.rpm -e elfutils
3.rpmbuild --rebuild <some_package>.src.rpm
4.Wait for build errors
  
Actual results:


Expected results:


Additional info:

Comment 1 Miloslav Trmac 2003-12-02 17:54:28 UTC
Triage->Easyfix

Comment 2 Jeff Johnson 2003-12-03 14:16:38 UTC
rpn-build has Requires: libelf.so.1 contained in
the elfutils packages already.

Comment 3 Maxim Dziumanenko 2003-12-04 13:46:37 UTC
libelf.so.1 belongs to elfutils-libelf, but 
eu-strip belongs to elfutils. This is the OTHER package.
elfutils-libelf doesn't depend on elfutils too.

Thus rpm-build should Requires: elfutils

Please, try to reproduce it.

Comment 4 Jeff Johnson 2003-12-05 14:03:45 UTC
eu-strip is mentioned only in find-debuginfo.sh, used to
produce -debuginfo packages, which is not enabled by default.

Hence no dependency.

Comment 5 Matthias Saou 2004-09-15 11:34:03 UTC
FWIW, I've opened bug #132633 in which I ask to have elfutils added as
a dependency to redhat-rpm-config, since that is the package
responsible for the debuginfo stuff and all. Seems like the right
solution to me.


Note You need to log in before you can comment on or make changes to this bug.