Bug 1113664 - [RFE] Separate indication of incoming and outgoing live migrations in "Virtual Machines" column of "Hosts" tab
Summary: [RFE] Separate indication of incoming and outgoing live migrations in "Virtua...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.3.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Martin Perina
QA Contact: Israel Pinto
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-06-26 15:00 UTC by Julio Entrena Perez
Modified: 2016-03-09 20:48 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
When performing migrations, numbered left and right arrows now indicate incoming and outgoing migrations in the 'Hosts' tab.
Clone Of:
Environment:
Last Closed: 2016-03-09 20:48:20 UTC
oVirt Team: Virt
sherold: Triaged+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0376 normal SHIPPED_LIVE Red Hat Enterprise Virtualization Manager 3.6.0 2016-03-10 01:20:52 UTC
oVirt gerrit 38324 master MERGED core: Add number of in/out migrations to VdsDynamic Never
oVirt gerrit 38325 master MERGED core: Populate number of in/out migrations from host statistics Never
oVirt gerrit 38326 master MERGED webadmin: Display number if in/out migrations per host Never
oVirt gerrit 38420 master MERGED host stats: Add number of in/out migrations Never
Red Hat Knowledge Base (Solution) 389623 None None None Never

Description Julio Entrena Perez 2014-06-26 15:00:28 UTC
Description of problem:
While VMs are live migrating between hosts the column "Virtual Machines" of the "Hosts" tab displays a left right arrow <--->  with the number of live migrating machines for each host	, but no indication of the direction of the live migrations is displayed.
Consequently users can not know if those VMs are migrating _in_ or _out_ of the host.

Version-Release number of selected component (if applicable):
rhevm-webadmin-portal-3.3.3-0.52.el6ev

How reproducible:
Always.

Steps to Reproduce:
1. Select multiple VMs running on host A and request those to migrate out of the host.
2. Select multiple VMs running on separate host B and request those to migrate to host A.
2. Observe "Virtual Machines" column in "Hosts" tab.

Actual results:
A left right arrow with the total number of VMs migrating _in_ and _out_ of the host is displayed (e.g. <--6-->).

Expected results:
A separate arrow for VMs migrating _in_ and VMs migrating _out_ is displayed (e.g. --4--> <--2-- indicating 4 VMs migrating out of the host and 2 VMs migrating in to the host).

Additional info:
For large hosts with big amounts of memory (e.g. 1TB) running hundreds of VMs the live migrations can take a long time to complete (30 - 60 minutes or more).
Users can not easily tell how many VMs are migrating in and out of a host for long periods of time.

Comment 1 Michal Skrivanek 2014-07-10 08:05:56 UTC
this has been implemented originally by SLA ~2 years ago by Laszlo, I'm sure there were some considerations about why it is the way it is…Doron?

Comment 2 Michal Skrivanek 2014-07-10 09:10:49 UTC
(actually should be this one - bug 970195)

Comment 3 Martin Tessun 2014-10-09 07:42:59 UTC
Hi Michal,

I think this is just an additional enhancement in getting a feeling what's going on in an environment.

Especially if you have a lot of migrations ongoing, you want to know if these are incoming or outgoing migrations.

So if there is a way (and I believe there is) to identify the incoming and outgoing migrations, it would be great to get this implemented within the RHEV 3 lifetime.

Cheers,
Martin

Comment 4 Michal Skrivanek 2015-03-09 10:58:05 UTC
I'd propose to calculate the value in vdsm and just send it to the engine as opposed to engine doing the calculation based on monitoring DB state.

Since vdsm is reporting total migrations since ages it's simpler to just extend it a little instead of adding a new partially redundant calculation in engine (with the risk of not being compeltely in sync due to async updates and monitoring cycle in engine) It's a lot more simple on the engine side

Comment 8 errata-xmlrpc 2016-03-09 20:48:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html


Note You need to log in before you can comment on or make changes to this bug.