Bug 1113674 - mousing over the org selector in UI raises menu that does not dismiss after mouse moves outside menu
Summary: mousing over the org selector in UI raises menu that does not dismiss after m...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: WebUI
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: Unspecified
Assignee: Tom McKay
QA Contact: jcallaha
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1141268 1146139 1160737 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-06-26 15:22 UTC by Tom McKay
Modified: 2019-08-15 03:53 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-11 03:38:28 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 1209323 0 None None None Never

Description Tom McKay 2014-06-26 15:22:39 UTC
Ever time mouse passes over the org selector menu (furthest left menu that displays current org context), the choice menu opens. Unlike the other menus, though, the org menu does not dismiss itself when the mouse leaves the area.

Comment 1 Tom McKay 2014-06-26 15:22:41 UTC
Created from redmine issue http://projects.theforeman.org/issues/6408

Comment 3 Dominic Cleal 2014-09-15 09:53:08 UTC
*** Bug 1141268 has been marked as a duplicate of this bug. ***

Comment 5 Dominic Cleal 2014-09-24 15:19:45 UTC
*** Bug 1146139 has been marked as a duplicate of this bug. ***

Comment 6 Tom McKay 2014-11-05 15:02:52 UTC
*** Bug 1160737 has been marked as a duplicate of this bug. ***

Comment 7 Bryan Kearney 2014-11-05 17:02:33 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/6408 has been closed
-------------
Thomas McKay
Applied in changeset commit:ee106539299e612c070adc16407eb70f8ab35f8f.

Comment 8 jcallaha 2014-11-14 18:42:06 UTC
Failed QA

If the mouse exits the org-switcher li to the left or up, then the drop down menu remains open. 

RHEL65 / RHEL7

Version Tested:
foreman-proxy-1.8.0-0.develop.201411121327gitab6edc2.el7.noarch
yttrium.idmqe.lab.eng.bos.redhat.com-foreman-proxy-1.0-1.noarch
foreman-gce-1.8.0-0.develop.201411131139git5cd6de6.el7.noarch
foreman-selinux-1.8.0-0.develop.201410280941git10de1c5.el7.noarch
foreman-vmware-1.8.0-0.develop.201411131139git5cd6de6.el7.noarch
foreman-release-1.8.0-0.develop.201411131139git5cd6de6.el7.noarch
ruby193-rubygem-foreman_discovery-1.4.0-2.el7.noarch
rubygem-hammer_cli_foreman_tasks-0.0.3-2.201409091410git163c264.git.0.988ca80.el7.noarch
foreman-postgresql-1.8.0-0.develop.201411131139git5cd6de6.el7.noarch
ruby193-rubygem-foreman_docker-0.2.0-2.el7.noarch
rubygem-hammer_cli_foreman-0.1.3-1.201411121216git9381fc5.el7.noarch
foreman-1.8.0-0.develop.201411131139git5cd6de6.el7.noarch
foreman-ovirt-1.8.0-0.develop.201411131139git5cd6de6.el7.noarch
ruby193-rubygem-foreman-tasks-0.6.9-1.el7.noarch
foreman-libvirt-1.8.0-0.develop.201411131139git5cd6de6.el7.noarch
foreman-compute-1.8.0-0.develop.201411131139git5cd6de6.el7.noarch
ruby193-rubygem-foreman_bootdisk-4.0.0-1.el7.noarch
yttrium.idmqe.lab.eng.bos.redhat.com-foreman-client-1.0-1.noarch
ruby193-rubygem-foreman_hooks-0.3.7-2.el7.noarch

Comment 9 Tom McKay 2015-03-09 14:19:02 UTC
The org switch, as it is currently written, works as well as it is going to. As the reporter, and the fixer, I am closing this as won't-fix. The changes I made make the behavior better but still not perfect, as noted by tester.

Comment 12 Bryan Kearney 2015-07-13 14:49:33 UTC
Connecting redmine issue http://projects.theforeman.org/issues/9293 from this bug

Comment 13 Stuart Auchterlonie 2015-11-04 10:29:52 UTC
I'm finding this issue extremely annoying every single time I use sat6


Note You need to log in before you can comment on or make changes to this bug.