Bug 1113709 - touchpad movement drastically reduced and unconfigurable in latest xorg-x11-server update
touchpad movement drastically reduced and unconfigurable in latest xorg-x11-s...
Status: CLOSED DUPLICATE of bug 1104789
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-06-26 13:16 EDT by Jason Montleon
Modified: 2014-06-27 15:20 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-26 21:25:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Montleon 2014-06-26 13:16:38 EDT
Description of problem:
Upon rebooting with xorg-x11-server-Xorg.x86_64 1.14.4-10.fc20 I found that my touchpad was extremely sluggish. I went into the Mouse and Touchpad settings in Xfce and attempted to adjust the Acceleration and Sensitivity but these had no effect. A full swipe across the touchpad might just move the cursor a couple inches across the screen. The same movement in xorg-x11-server-Xorg-1.14.4-5.fc20.x86_64 can get me 80% across the screen.

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg.x86_64 1.14.4-10.fc20

How reproducible:
Always

Steps to Reproduce:
1. Use your touchpad in Fedora 20 with xorg-x11-server-Xorg-1.14.4-5.fc20.x86_64
2. Upgrade to xorg-x11-server-Xorg.x86_64 1.14.4-10.fc20

Actual results:
Notice a drastic decrease in motion and that it seems to be unconfigurable.

Expected results:
Mouse behaves the same as in previous releases.

Additional info:
Downgrading to xorg-x11-server-Xorg-1.14.4-5.fc20.x86_64 restores the old behavior. 

The touchpad is listed as ETPS/2 Elantech Touchpad in Xfce Mouse and Touchpad

/proc/bus/input/devices has it as:
I: Bus=0011 Vendor=0002 Product=000e Version=0000
N: Name="ETPS/2 Elantech Touchpad"
P: Phys=isa0060/serio1/input0
S: Sysfs=/devices/platform/i8042/serio1/input/input7
U: Uniq=
H: Handlers=mouse0 event5 
B: PROP=1
B: EV=b
B: KEY=6420 30000 0 0 0 0
B: ABS=260800011000003

Bluetooth mouse seems unaffected by this problem:
I: Bus=0005 Vendor=19ff Product=0207 Version=0245
N: Name="Rocketfish Apple Bluetooth Mouse"
P: Phys=68:94:23:97:23:18
S: Sysfs=/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.1/1-1.1:1.0/bluetooth/hci0/hci0:21/0005:19FF:0207.0001/input/input16
U: Uniq=00:02:76:0f:bd:59
H: Handlers=mouse1 event14 
B: PROP=0
B: EV=17
B: KEY=1f0000 0 0 0 0
B: REL=343
B: MSC=10
Comment 1 Jason Montleon 2014-06-26 13:24:11 EDT
xorg-x11-server-Xorg-1.14.4-9 seems to work fine, so I guess it's just -10 that is affected thus far.
Comment 2 Dezponia Veil 2014-06-26 18:05:06 EDT
Can confirm this issue on two of my laptops, both using ALPS touchpads. They both also have trackpoints which are unaffected. USB mice I've tried have been unaffected.

This is /proc/bus/input/devices from the laptop I'm on now.

I: Bus=0011 Vendor=0002 Product=0008 Version=0300
N: Name="AlpsPS/2 ALPS DualPoint TouchPad"
P: Phys=isa0060/serio1/input0
S: Sysfs=/devices/platform/i8042/serio1/input/input6
U: Uniq=
H: Handlers=mouse1 event6 
B: PROP=8
B: EV=b
B: KEY=e420 70000 0 0 0 0
B: ABS=260800001000003


Downgrading to xorg-x11-server-Xorg-1.14.4-5.fc20.x86_64 which is what I had before -10 solved it for me on both laptops.
Comment 3 Peter Hutterer 2014-06-26 21:25:52 EDT
Fallout from 1104789, revert is underway though I'm not sure what the problem is yet.

*** This bug has been marked as a duplicate of bug 1104789 ***

Note You need to log in before you can comment on or make changes to this bug.