Bug 1113753 - Firebug complains 'Response is not valid JSON' on clicking a custom product repo
Summary: Firebug complains 'Response is not valid JSON' on clicking a custom product repo
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Katello Bug Bin
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-06-26 20:12 UTC by sthirugn@redhat.com
Modified: 2019-09-26 13:47 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:09:38 UTC
Target Upstream Version:


Attachments (Terms of Use)
firebug warning invalid json (150.90 KB, image/png)
2014-06-26 20:12 UTC, sthirugn@redhat.com
no flags Details
Product showing 3 repos (72.91 KB, image/png)
2014-06-26 20:33 UTC, sthirugn@redhat.com
no flags Details
Sync status showing 4 custom repos (61.23 KB, image/png)
2014-06-26 20:34 UTC, sthirugn@redhat.com
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC

Description sthirugn@redhat.com 2014-06-26 20:12:06 UTC
Description of problem:
Firebug complains 'Response is not valid JSON' on clicking a custom product repo

Version-Release number of selected component (if applicable):
* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.19-1.el6_5.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.9.19-1.el6_5.noarch
* candlepin-tomcat6-0.9.19-1.el6_5.noarch
* elasticsearch-0.90.10-4.el6sat.noarch
* foreman-1.6.0.21-1.el6sat.noarch
* foreman-compute-1.6.0.21-1.el6sat.noarch
* foreman-gce-1.6.0.21-1.el6sat.noarch
* foreman-libvirt-1.6.0.21-1.el6sat.noarch
* foreman-ovirt-1.6.0.21-1.el6sat.noarch
* foreman-postgresql-1.6.0.21-1.el6sat.noarch
* foreman-proxy-1.6.0.9-1.el6sat.noarch
* foreman-selinux-1.6.0-4.el6sat.noarch
* foreman-vmware-1.6.0.21-1.el6sat.noarch
* katello-1.5.0-26.el6sat.noarch
* katello-ca-1.0-1.noarch
* katello-certs-tools-1.5.5-1.el6sat.noarch
* katello-installer-0.0.53-1.el6sat.noarch
* openldap-2.4.23-32.el6_4.1.x86_64
* pulp-katello-0.3-3.el6sat.noarch
* pulp-nodes-common-2.4.0-0.23.beta.el6sat.noarch
* pulp-nodes-parent-2.4.0-0.23.beta.el6sat.noarch
* pulp-puppet-plugins-2.4.0-0.23.beta.el6sat.noarch
* pulp-puppet-tools-2.4.0-0.23.beta.el6sat.noarch
* pulp-rpm-plugins-2.4.0-0.23.beta.el6sat.noarch
* pulp-selinux-2.4.0-0.23.beta.el6sat.noarch
* pulp-server-2.4.0-0.23.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.1.0-2.el6sat.noarch

How reproducible:
Always

Steps to Reproduce:
1. Create a custom product p1
2. Go to the product p1 and create a new repository by clicking 'Create Repository'. Create a new repository in p1. I entered: Name, Label, Type=yum, URL. Click Save.
3. Click on the newly created repo again.

Actual results:
Notice the firebug warning (Response is not valid JSON) (Screenshot attached)

Expected results:
No firebug warnings or errors

Additional info:

Comment 1 sthirugn@redhat.com 2014-06-26 20:12:29 UTC
Created attachment 912558 [details]
firebug warning invalid json

Comment 3 sthirugn@redhat.com 2014-06-26 20:33:26 UTC
Created attachment 912571 [details]
Product showing 3 repos

Comment 4 sthirugn@redhat.com 2014-06-26 20:34:05 UTC
Created attachment 912573 [details]
Sync status showing 4 custom repos

Comment 5 sthirugn@redhat.com 2014-06-26 20:34:37 UTC
FWIW - here in the test custom product - I tried adding a repo called 'sat6repo' but the save did not complete so I refreshed the page.  But it looks like it got added in the backend but it is not showing in Product -> Repositories (see screenshot Product showing 3 repos.png).  But the Sync status page says that the product has 4 repos (see screenshot Sync status showing 4 custom repos.png).  I am not sure if this is the reason for the json error.  But this is worth investigating.

Comment 6 Brad Buckingham 2015-08-27 15:58:17 UTC
I am not seeing this issue with Satellite 6.1.1 GA; therefore, going to move ON_QA for verification.

builds:
foreman-1.7.2.34-1.el7sat.noarch
ruby193-rubygem-katello-2.2.0.66-1.el7sat.noarch

firefox 38.0

Comment 7 sthirugn@redhat.com 2016-03-18 19:48:51 UTC
Verifeid in Satellite 6.2.0-beta-snap4

Comment 10 errata-xmlrpc 2016-07-27 09:09:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.