Bug 11139 - Broken SoundBlaster 16 (orig) support
Broken SoundBlaster 16 (orig) support
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: sndconfig (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-01 01:51 EDT by casey
Modified: 2014-03-16 22:13 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-14 18:08:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description casey 2000-05-01 01:51:24 EDT
After upgrading to RHL6.2 (with stock i586 kernel, ver 2.2.14-5.0) from
RHL6.0, my soundblaster compatible ES1688 AudioDrive would only play XMMS,
RealPlayer, and WAV files *slowly* (about 1/10th speed).  Using:
cat /path/to/someAUfile.au > /dev/audio  plays fine.

Worked with a variety of /etc/conf.modules settings including:
alias sound-slot-0 sb
options sound dmabuf=1
alias sound sb
alias midi opl3
options opl3 io=0x388
options sb io=0x220 irq=10 dma=1 dma16=7 mpu_io=0x300

No conflicts in /proc (dma, ioports, interrupts)

Tried new kernel update, 2.2.14-6.0.1, without any change.  Installed
kernel 2.2.5-22 and everything works great!

My assumption as a result is that the problem is in
/lib/modules/2.2.14-6.0.1/misc/sb.o  however I haven't tried recompiling
this module to verify this.

Hope this helps,  -Casey
Comment 1 Bill Nottingham 2000-05-01 12:12:59 EDT
Add to the end of the 'options sb' line in
/etc/conf.modules:

esstype=1688

(You might need to try other values; the list
of values you can try are:
0,688,1688,1868,1869,1788,1887,1888)
Comment 2 Alan Cox 2002-12-14 18:08:00 EST
Long fixed for the general case. Some setups cant be hand detected alas and will
always need the above

Note You need to log in before you can comment on or make changes to this bug.