Bug 1113978 - netcf should emit DHCPV6C to ifcfg-* files for ipv6 family rather than "DHCPV6"
Summary: netcf should emit DHCPV6C to ifcfg-* files for ipv6 family rather than "DHCPV6"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: netcf
Version: 6.6
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Laine Stump
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-06-27 11:45 UTC by Hu Jianwei
Modified: 2015-07-22 06:26 UTC (History)
6 users (show)

Fixed In Version: netcf-0.2.4-2.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-07-22 06:26:02 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1307 normal SHIPPED_LIVE netcf bug fix update 2015-07-20 17:53:43 UTC

Description Hu Jianwei 2014-06-27 11:45:55 UTC
Description of problem:
libvirt should emit DHCPV6C to ifcfg-* files for ipv6 family, rather than "DHCPV6"

Version-Release number of selected component (if applicable):
netcf-0.2.4-1.el6.x86_64
libvirt-0.10.2-38.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
[root@rhel6 ~]# virsh iface-dumpxml eth1
<interface type='ethernet' name='eth1'>
  <start mode='none'/>
  <mac address='00:1B:21:27:4E:CE'/>
  <mtu size='1500'/>
  <protocol family='ipv6'>
    <dhcp/>
  </protocol>
</interface>

[root@rhel6 ~]# cat /etc/sysconfig/network-scripts/ifcfg-eth1
DEVICE=eth1
HWADDR=00:1B:21:27:4E:CE
ONBOOT=no
MTU=1500
IPV6INIT=yes
IPV6_AUTOCONF=no
DHCPV6=yes

Actual results:
As shown above steps, libvirt pass a incorrect "DHCPV6" to ifcfg-eth1.

[root@rhel6 network-scripts]# cat ifcfg-eth1
DEVICE=eth1
HWADDR=00:1B:21:27:4E:CE
ONBOOT=no
MTU=1500
IPV6INIT=yes
IPV6_AUTOCONF=no
DHCPV6=yes

[root@rhel6 network-scripts]# ifup eth1
RTNETLINK answers: File exists
Global IPv6 forwarding is disabled in configuration, but not currently disabled in kernel
Please restart network with '/sbin/service network restart'

Expected results:
Libvirt should pass a right option DHCPV6C to configurtion.

[root@rhel6 network-scripts]# cat ifcfg-eth1
DEVICE=eth1
HWADDR=00:1B:21:27:4E:CE
ONBOOT=no
MTU=1500
IPV6INIT=yes
IPV6_AUTOCONF=no
DHCPV6C=yes

[root@rhel6 network-scripts]# ifup eth1
RTNETLINK answers: File exists
Global IPv6 forwarding is disabled in configuration, but not currently disabled in kernel
Please restart network with '/sbin/service network restart'

Determining IPv6 information for eth1...^C

Comment 2 Laine Stump 2014-08-13 18:08:35 UTC
I sent a patch for this upstream:

https://lists.fedorahosted.org/pipermail/netcf-devel/2014-August/000896.html

Comment 4 Laine Stump 2014-08-20 13:39:32 UTC
The patch was pushed upstream:

commit 3806b2103f7e07eaa56bd60841c82b0dc4dc3f3e
Author: Laine Stump <laine@laine.org>
Date:   Wed Aug 13 12:57:09 2014 -0400

    Fix name of DHCPV6C variable in ifcfg files
    
    This is a *very* longstanding bug, which shows that nobody using DHCP
    on IPv6 is using netcf - the name of the DHCPV6C variable was
    incorrectly put in as DHCPV6 all the way back when the netcf package
    was first written, and nobody noticed, until this bug was filed:

Comment 9 Hu Jianwei 2015-02-12 08:50:24 UTC
I can not reproduce it on below version:

[root@intel-e31225-8-3 ~]# rpm -q libvirt netcf
libvirt-0.10.2-49.el6.x86_64
netcf-0.2.4-2.el6.x86_64

[root@intel-e31225-8-3 ~]# cat eth1.xml 
<interface type='ethernet' name='eth1'>
  <start mode='none'/>
  <mac address='00:1B:21:27:4E:CE'/>
  <mtu size='1500'/>
  <protocol family='ipv6'>
    <dhcp/>
  </protocol>
</interface>

<1> Using virsh iface-* cmds
[root@intel-e31225-8-3 ~]# virsh iface-define eth1.xml 
Interface eth1 defined from eth1.xml

[root@intel-e31225-8-3 ~]# virsh iface-dumpxml eth1
<interface type='ethernet' name='eth1'>
  <start mode='none'/>
  <mac address='00:1B:21:27:4E:CE'/>
  <mtu size='1500'/>
  <protocol family='ipv6'>
    <dhcp/>
  </protocol>
</interface>

[root@intel-e31225-8-3 ~]# cat /etc/sysconfig/network-scripts/ifcfg-eth1 
DEVICE=eth1
HWADDR=00:1B:21:27:4E:CE
ONBOOT=no
MTU=1500
IPV6INIT=yes
IPV6_AUTOCONF=no
DHCPV6C=yes

[root@intel-e31225-8-3 ~]# virsh iface-undefine eth1
Interface eth1 undefined

[root@intel-e31225-8-3 ~]# cat /etc/sysconfig/network-scripts/ifcfg-eth1 
cat: /etc/sysconfig/network-scripts/ifcfg-eth1: No such file or directory

<2> Using ncftool 
[root@intel-e31225-8-3 ~]# ncftool define eth1.xml 
Defined interface eth1

[root@intel-e31225-8-3 ~]# cat /etc/sysconfig/network-scripts/ifcfg-eth1 
DEVICE=eth1
HWADDR=00:1B:21:27:4E:CE
ONBOOT=no
MTU=1500
IPV6INIT=yes
IPV6_AUTOCONF=no
DHCPV6C=yes

[root@intel-e31225-8-3 ~]# ncftool dumpxml eth1
<?xml version="1.0"?>
<interface type="ethernet" name="eth1">
  <start mode="none"/>
  <mac address="00:1B:21:27:4E:CE"/>
  <mtu size="1500"/>
  <protocol family="ipv6">
    <dhcp/>
  </protocol>
</interface>

We can get expected results, move to Verified.

Comment 12 errata-xmlrpc 2015-07-22 06:26:02 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1307.html


Note You need to log in before you can comment on or make changes to this bug.