Bug 1114009 - flooding console output during rhpkg switch-branch
Summary: flooding console output during rhpkg switch-branch
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rpkg
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Pavol Babinčák
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 1119216 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-06-27 12:42 UTC by Petr Holasek
Modified: 2016-10-04 04:12 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-07-30 08:53:41 UTC


Attachments (Terms of Use)

Description Petr Holasek 2014-06-27 12:42:41 UTC
Description of problem:
There is *a lot of* output rhkpg switch-branch in my kernel repo related to branch changes.

Version-Release number of selected component (if applicable):
1.18-2.fc20

How reproducible:
every time in my kernel repository. I don't see this issue with other package's repositories.

Steps to Reproduce:
1. rhpkg switch-branch rhel-6.5

Actual results:
<snip>
private-mleitner-sf00639891 -> origin/private-mleitner-sf00639891', ' = [up to date]      private-mleitner-sf00640186 -> origin/private-mleitner-sf00640186', ' = [up to date]      private-mleitner-sf00641626_el5 -> origin/private-mleitner-sf00641626_el5', ' = [up to date]      private-mleitner-sf00664851-tst1 -> origin/private-mleitner-sf00664851-tst1', ' = [up to date]      private-mleitner-sf00672997 -> origin/private-mleitner-sf00672997', ' = [up to date]      private-mleitner-sf00682825 -> origin/private-mleitner-sf00682825', ' = [up to date]      private-mleitner-sf00692671 -> origin/private-mleitner-sf00692671', ' = [up to date]      private-mleitner-sf00698457 -> origin/private-mleitner-sf00698457', '1', 'l', '8_9_1_1', 'd', 'f-sched_debug_off'])
<snip>

and branch is checked out correctly 

Expected results:

checked out branch without any messages.

Additional info:

I didn't modified any .git internals of the repo and I didn't see the problem with another repositories. Maybe is it related to the number of existing branches? Anyway, git checkout command works well.

Comment 1 Pavol Babinčák 2014-07-14 10:43:14 UTC
*** Bug 1119216 has been marked as a duplicate of this bug. ***

Comment 2 Jes Sorensen 2014-07-14 10:52:45 UTC
Pavol,

This may be the same problem as 1119216, however the reason why I didn't dupe
it was that in the case of 1119216, the branch is *not* switched at all.

Jes

Comment 3 Pavol Babinčák 2014-07-14 11:05:43 UTC
(In reply to Jes Sorensen from comment #2)
> This may be the same problem as 1119216, however the reason why I didn't dupe
> it was that in the case of 1119216, the branch is *not* switched at all.
Does workaround:
git checkout $BRANCH #e.g. BRANCH=rhel-7.0
work for you?

Comment 4 Jes Sorensen 2014-07-14 11:54:20 UTC
Yes, I can do 'git checkout rhel-x.y'

However is that really all rhpkg switch-branch does ?

Jes

Comment 5 Pavol Babinčák 2014-07-14 12:09:22 UTC
(In reply to Jes Sorensen from comment #4)
> However is that really all rhpkg switch-branch does ?
It does only following things:
1. check if repository isn't dirty and deny switch branch in this case

2. fetch new branches from the server (by default in this version, which most likely is the source of this bug)

3. a) if requested branch isn't local yet, runs
      git checkout -b $BRANCH --track origin/$BRANCH
   b) if requested branch is local runs:
      git checkout $BRANCH

Comment 16 Jes Sorensen 2014-07-29 08:00:26 UTC
FWIW I now see the same with 'fedpkg' when dealing with the Fedora package
I maintain.

Any ETA for a fix?

Jes

Comment 17 Pavol Babinčák 2014-07-29 13:04:27 UTC
(In reply to Jes Sorensen from comment #16)
> FWIW I now see the same with 'fedpkg' when dealing with the Fedora package
> I maintain.
You should be able to use:
 $ fedpkg switch-branch --no-fetch $BRANCH
too. I'd like to release fixed rpkg no later than tomorrow.

Comment 18 Fedora Update System 2014-07-30 11:55:46 UTC
fedpkg-1.18-1.fc19,rpkg-1.26-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/fedpkg-1.18-1.fc19,rpkg-1.26-1.fc19

Comment 19 Fedora Update System 2014-07-30 12:00:52 UTC
fedpkg-1.18-1.fc20,rpkg-1.26-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/fedpkg-1.18-1.fc20,rpkg-1.26-1.fc20

Comment 20 Fedora Update System 2014-07-30 12:20:04 UTC
fedpkg-1.18-1.el6,rpkg-1.26-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/fedpkg-1.18-1.el6,rpkg-1.26-1.el6

Comment 21 Fedora Update System 2014-08-08 08:40:07 UTC
fedpkg-1.18-1.fc20, rpkg-1.26-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 22 Fedora Update System 2014-08-15 02:54:45 UTC
fedpkg-1.18-1.fc19, rpkg-1.26-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 23 Fedora Update System 2014-08-15 18:59:29 UTC
fedpkg-1.18-1.el6, rpkg-1.26-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.