Bug 111413 - MySQL using exessive processing power and sluggish queries
MySQL using exessive processing power and sluggish queries
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: mysql (Show other bugs)
3.0
i686 Linux
high Severity medium
: ---
: ---
Assigned To: Patrick Macdonald
http://www.bpweb.net/top_mysql.jpg
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-03 07:10 EST by Nick Byng
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-04 15:17:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nick Byng 2003-12-03 07:10:43 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
The MySQL version in question was downloaded from the Red Hat Network 
Enterprise ES 3 Extras channel.

This MySQL version seems to be using exessive processing power and 
queries seem sluggish compared to the install running on a RH7.2 
machine we use. (default 3.23.58 rpm install)

We had a big web-site on our 7.2 machine that was quite heavy on 
MySQL. After moving to our new ES3 server MySQL uses a lot more 
processing power, even though the system has double the RAM, 
processing power e.t.c

The system spec is:

2.8Ghz P4
2GB PC2700 DDR RAM
2x 120GB Western Digital IDE Hard Disks
Asus P4P800-VM "i865G" Motherboard

Using TOP and PS commands, I also notice that there is never more 
than 1 MySQL process in the process list. Im not sure if this is 
normal, as on the 7.2 machines there are always many MySQL processes 
in the list.

The URL supplied is a screenshot of TOP showing the big processor 
usage. Note the time this process has been running, I guess due to it 
being the only process handling MySQL requests.


Version-Release number of selected component (if applicable):
mysql-server-3.23.58-1

How reproducible:
Always

Steps to Reproduce:
1. Run queries on a moderate to large database
    

Actual Results:  MySQL uses a lot of processing power, only one 
process seems to handle all of the requests.

Expected Results:  mysql processes using less CPU power, more than 
one MySQL process in the process list.

Additional info:
Comment 1 Patrick Macdonald 2003-12-04 15:17:13 EST
I'm really not sure what you expect us to do here.  You have not
included any code samples of what is slowing down.  MySQL 3.23.58
is not, from a modification point of view, terribly different than
prior 3.23 releases (ie. it's just a bug fix release).

I'd take a look at any performance tuning you did on 7.2 and port it
to ES.  You may also want to take a look at the performance tips
listed on the MySQL web site (www.mysql.com).
Comment 2 Kevin M. Myer 2004-03-23 22:46:07 EST
I believe the behavior this gentleman is concerned about is that mysql is running with a 
single process.  Previous versions had forked several mysqld processes.  I'm seeing the 
same thing on my database server.

Code samples are not really relevant - I'm essentially running a dual process (actually 
quad if you count the hyperthreaded processors) in single processor mode, with one 
thread of mysqld.  Essentially, mysqld appears to have been started with the "--one-
thread" option but that option isn't being passed on the command line for startup...

So, off to see if I can figure out what is going on...
Comment 3 Kevin M. Myer 2004-03-23 22:53:10 EST
Arg, nevermind - they're there, they are threads, though so they don't show up with 
normal ps auxw output :)  Should have checked mysqladmin extended-status first...

Note You need to log in before you can comment on or make changes to this bug.