Bug 1114180 - Touchpad Cursor is moving slow
Touchpad Cursor is moving slow
Status: CLOSED DUPLICATE of bug 1104789
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
20
i686 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Orphan Owner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-06-28 04:31 EDT by Iosif Bancioiu
Modified: 2014-06-28 07:01 EDT (History)
19 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-28 07:01:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Iosif Bancioiu 2014-06-28 04:31:13 EDT
Description of problem:

The cursor is moving very slow when using touchpad PS/AS2 - Dell Vostro 1015 from the las updates and there is no way to fix it. I tried to fix it from touchpad sensitivity (KDE Settings) and it dosen't works, more if I try to set it to high, the touchpad is not working.

Version-Release number of selected component (if applicable):
1.7.6-2F20.i686




How reproducible:
On every reboot I have the same problem


Steps to Reproduce:
1. Reboot

Actual results:
Not working

Expected results:
To work

Additional info:
Comment 1 Scott Dowdle 2014-06-28 06:00:27 EDT
I too have this problem that started yesterday with the touchpad on my Dell Lattitude D630.  It is like the touchpad's reach on the screen is about 20px x 40px doing a full motion square on the outside of the track pad.  Moving across my entire screen (1440x900) from bottom left corner to top right corner takes around 36-38 full swipes.

Luckily this laptop also has an eraser head pointer device that is functioning normally.

I'm using XFCE at the moment (I have most desktop environments installed and can switch easily) and the touchpad settings, like the reporter's KDE settings, made no difference.

The xorg-x11-drv-synaptics package was last updated in mid May.  The xorg-x11-server-common package was just updated yesterday so I suspect that is the cause of this painful change... and specifically this from its changelog:

* Mon Jun 23 2014 Peter Hutterer <peter.hutterer@redhat.com> 1.14.4-10
- Fix coordinate scaling so we're independent of the screen res (#1104789)

I think I'll jump on that bug report too.
Comment 2 Iosif Bancioiu 2014-06-28 06:32:22 EDT
So what sould i do? Set xorg-x11-server-common package as the package problem? My native language is not En. and i don't get the last part

"* Mon Jun 23 2014 Peter Hutterer <peter.hutterer@redhat.com> 1.14.4-10
- Fix coordinate scaling so we're independent of the screen res (#1104789)

I think I'll jump on that bug report too."
Comment 3 Scott Dowdle 2014-06-28 06:49:18 EDT
Here's that bug that had a fix that caused this bug:

https://bugzilla.redhat.com/show_bug.cgi?id=1104789

I imagine it's up to the assigned person if they want to keep this, change what package it is associated with, or mark as a duplicate.  You might want to add comment on the other bug report to say that the fix broke your system too.
Comment 4 Iosif Bancioiu 2014-06-28 07:01:08 EDT
(In reply to Scott Dowdle from comment #3)
> Here's that bug that had a fix that caused this bug:
> 
> https://bugzilla.redhat.com/show_bug.cgi?id=1104789
> 
> I imagine it's up to the assigned person if they want to keep this, change
> what package it is associated with, or mark as a duplicate.  You might want
> to add comment on the other bug report to say that the fix broke your system
> too.

Yes, it is fixed by the new testing update
sudo yum update --enablerepo=updates-testing xorg-x11-*
Comment 5 Iosif Bancioiu 2014-06-28 07:01:55 EDT

*** This bug has been marked as a duplicate of bug 1104789 ***

Note You need to log in before you can comment on or make changes to this bug.