Bug 1114195 - Dell Latitude E6230: Touchpad is very slow.
Dell Latitude E6230: Touchpad is very slow.
Status: CLOSED DUPLICATE of bug 1104789
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
20
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-06-28 10:07 EDT by Hajime Taira
Modified: 2014-06-30 12:15 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-29 07:26:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hajime Taira 2014-06-28 10:07:11 EDT
Description of problem:
Touchpad is very slow when I installed 1.14.4-10.fc20.

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.14.4-10.fc20.x86_64
xorg-x11-server-common-1.14.4-10.fc20.x86_64

How reproducible:

Steps to Reproduce:
1. yum update xorg-x11-server-Xorg at latest (1.14.4-10.fc20)
2. reboot
3. launch X11

Actual results:
Slowest cursor

Additional info:
$ xinput --list
⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
⎜   ↳ Genius 2.4G Wireless Mouse              	id=14	[slave  pointer  (2)]
⎜   ↳ AlpsPS/2 ALPS GlidePoint                	id=16	[slave  pointer  (2)]
⎜   ↳ ALPS PS/2 Device                        	id=17	[slave  pointer  (2)]
⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
    ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
    ↳ Power Button                            	id=6	[slave  keyboard (3)]
    ↳ Video Bus                               	id=7	[slave  keyboard (3)]
    ↳ Power Button                            	id=8	[slave  keyboard (3)]
    ↳ Sleep Button                            	id=9	[slave  keyboard (3)]
    ↳ Laptop_Integrated_Webcam_E4HD           	id=13	[slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard            	id=15	[slave  keyboard (3)]
    ↳ Dell WMI hotkeys                        	id=18	[slave  keyboard (3)]

ALPS PS/2 Device is touchpad device on Dell Latitude E6230.

Workaroud is here.
1.14.4-5.fc20.x86_64 doesn't affect this problem.
# yum downgrade xorg-x11-server-Xorg xorg-x11-server-common

# rpm -q xorg-x11-server-Xorg xorg-x11-server-common
xorg-x11-server-Xorg-1.14.4-5.fc20.x86_64
xorg-x11-server-common-1.14.4-5.fc20.x86_64
Comment 1 Bert DeKnuydt 2014-06-28 10:31:14 EDT
Same here on a Dell 610 and a few other more recent Dell's.

Another workaround:

  synclient minspeed=10

from a terminal.  This of course does not survive a boot.

'G-spot' on the same machine is not affected.
Comment 2 Matt Smith 2014-06-28 20:08:09 EDT
This affected me after the last update. I was also able to use synclient MinSpeed=10 to get my touchpad to a usable speed. This mght be a problem with the gnome-settings-daemon since that also updated about the same time.
Comment 3 Hans de Goede 2014-06-29 07:26:38 EDT

*** This bug has been marked as a duplicate of bug 1104789 ***
Comment 4 Matt Smith 2014-06-29 18:06:17 EDT
I don't have an additional monitor, I do not understand how this is a duplicate.
Comment 5 Hajime Taira 2014-06-29 20:56:28 EDT
I don't have external monitor too.
Comment 6 Hans de Goede 2014-06-30 01:58:51 EDT
(In reply to Matt Smith from comment #4)
> I don't have an additional monitor, I do not understand how this is a
> duplicate.

Have you tried actually reading the bug this is marked as a duplicate of ?

Note that, as mentioned in that bug, "sudo yum update --enablerepo=updates-testing xorg-x11-*" will fix this.
Comment 7 Matt Smith 2014-06-30 04:13:16 EDT
Yes, I tried reading the bug. I found that it described a similar effect but with a different environment. I also found that it was posted before I started having trouble with my touchpad. I didn't read all of the comments because it does not appear to be the same bug. So I asked the question here.
Comment 8 Hajime Taira 2014-06-30 12:15:40 EDT
I tried to apply following packages from update-testing repo.
It fixed this issue in my environment (Dell Latitude E6230).

xorg-x11-server-common-1.14.4-11.fc20.x86_64
xorg-x11-server-Xorg-1.14.4-11.fc20.x86_64

Note You need to log in before you can comment on or make changes to this bug.