Bug 11142 - Printtool STILL broken
Summary: Printtool STILL broken
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: printtool (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-05-01 13:11 UTC by andy
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-03 14:01:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description andy 2000-05-01 13:11:26 UTC
Printtool is still not detecting all local printers.
After upgrading 2 machines this weekend one now sees a local printer,
but the other doesn't.
This main server has been unable to print now for TWO releases!

parport errors are still being reported on startup. From messages:

May  1 12:18:38 neuromancer lpd: lpd startup succeeded
May  1 12:18:38 neuromancer kernel: parport0: PC-style at 0x378
[SPP,ECP,ECPEPP,ECPPS2]
May  1 12:18:38 neuromancer kernel: parport0: detected irq 7; use procfs to
enable interrupt-driven operation.
May  1 12:18:39 neuromancer kernel: Installing knfsd (copyright (C) 1996
okir@monad.swb.de).
May  1 12:18:39 neuromancer nfs: Starting NFS services:  succeeded
May  1 12:18:39 neuromancer kernel: parport0: no IEEE-1284 device present.
May  1 12:18:39 neuromancer kernel: lp0: using parport0 (polling).

Comment 1 andy 2000-05-01 20:27:59 UTC
Setting the parallel-port to SPP in bios removes the warning, and the port is
detected. However I can't get any output.
Printter is Cannon 610 (the same printer does print whan connectted to second
RH62 machine).

Printcap:

lp:\
        :sd=/var/spool/lpd/lp:\
        :mx#0:\
        :sh:\
        :lp=/dev/lp0:\
        :if=/var/spool/lpd/lp/filter:

Q: What should the bios setting be?

Comment 2 Bernhard Rosenkraenzer 2000-05-03 14:01:59 UTC
printtool works for everyone else (including your other machine), so I'm
expecting this is a problem with your setup.
Autodetection may not work if your printer does not support the IEEE-1284
standard (most new printers do, most older printers don't).
The SPP mode doesn't support IEEE-1284 checking, so the warning message goes
away because the probing isn't tried.

Does something simple like

echo "Linux" >/dev/lp0

work?
(Trying to determine if it's a problem with the port or with your setup)


Note You need to log in before you can comment on or make changes to this bug.