Bug 111430 - subscript out of range
subscript out of range
Status: CLOSED DUPLICATE of bug 80826
Product: Fedora
Classification: Fedora
Component: vixie-cron (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-03 12:25 EST by d.binderman
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description d.binderman 2003-12-03 12:25:48 EST
Description of problem:
I just tried to compile package vixie-cron-3.0.1-76 from Fedora.

The compiler said

entry.c(152): warning #175: subscript out of range

The source code is

	bit_set(e->hour, (LAST_HOUR-FIRST_HOUR+1));

It makes no sense to set a bit one past the size of the array.

I am not sure what the fix is for this.



Version-Release number of selected component (if applicable):
vixie-cron-3.0.1-76 

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Miloslav Trmac 2004-02-07 11:46:42 EST

*** This bug has been marked as a duplicate of 80826 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:00:16 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.