Bug 1114397 - Please rebase bluedevil
Summary: Please rebase bluedevil
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: bluedevil
Version: 20
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Jaroslav Reznik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-06-30 00:14 UTC by Kevin Clevenger
Modified: 2014-07-23 03:00 UTC (History)
7 users (show)

Fixed In Version: libbluedevil-2.0-0.9.rc1.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-23 03:00:57 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
KDE Software Compilation 329403 None None None Never
KDE Software Compilation 337193 None None None Never

Comment 1 Kevin Kofler 2014-06-30 01:14:45 UTC
Some context would be helpful, so let me add it for you. ;-)

The upstream bug report you linked references a crash fix:

Git commit 335d81d90d6b92b07b120d334958a2ae9b70c565 by Àlex Fiestas.
Committed on 09/03/2014 at 02:42.
Pushed by afiestas into branch 'master'.

[wizard] Better handling when no adapter is usable

Be more careful if at any moment in the Discover page
the Adapter stops being usable.

M  +5    -0    src/wizard/bluewizard.cpp
M  +4    -0    src/wizard/pages/discoverpage.cpp

http://commits.kde.org/bluedevil/335d81d90d6b92b07b120d334958a2ae9b70c565

Comment 2 Fedora Update System 2014-06-30 16:49:00 UTC
bluedevil-2.0.0-0.13.36f0438agit20140630.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/bluedevil-2.0.0-0.13.36f0438agit20140630.fc20

Comment 3 Fedora Update System 2014-07-01 07:22:15 UTC
Package bluedevil-2.0.0-0.13.36f0438agit20140630.fc20, libbluedevil-2.0-0.8.rc1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing bluedevil-2.0.0-0.13.36f0438agit20140630.fc20 libbluedevil-2.0-0.8.rc1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-7944/libbluedevil-2.0-0.8.rc1.fc20,bluedevil-2.0.0-0.13.36f0438agit20140630.fc20
then log in and leave karma (feedback).

Comment 4 Stan Trzmiel 2014-07-07 16:19:30 UTC
Latest update from comment above caused quite opposite situation, Bluedevil stopped to recognise BT adapter.
See upstream bug: https://bugs.kde.org/show_bug.cgi?id=337193

Comment 5 Kevin Clevenger 2014-07-07 16:23:32 UTC
I noticed that same thing - I had to set Bluetooth->Adapters->Powered on every resume/reboot, and the changes from upstream did not affect bluebooth usability in any appreciable way.

Comment 6 Rex Dieter 2014-07-07 16:41:23 UTC
Not recognizing BT adapter isn't the same as power status.

Does your machine have a bluetooth power/kill switch?  

I ask because the power status change here is a result of a recent upstream commit to not change power status of bluetooth adapters (prior it would power them on unconditionally, if I'm reading the code correctly).

Comment 7 Kevin Clevenger 2014-07-07 16:53:15 UTC
Rex - yes my laptop does have a physical wifi/BT off switch, but it was in the "on" position for my testing of course

Comment 8 Rex Dieter 2014-07-07 16:56:24 UTC
OK, seems I can reproduce the problem now too, I'll revoke the update and do more testing.

Comment 9 Stan Trzmiel 2014-07-07 17:09:53 UTC
(In reply to Kevin Clevenger from comment #5)
> I noticed that same thing - I had to set Bluetooth->Adapters->Powered on
> every resume/reboot, and the changes from upstream did not affect bluebooth
> usability in any appreciable way.

Nope no physical switch here. Usually my BT adapter is powered on after each reboot/resume. Bluedevil gives me no options, just says there's no adapter found.

Comment 10 Rex Dieter 2014-07-07 17:52:22 UTC
I think it comes from this commit:
https://projects.kde.org/projects/playground/libs/libbluedevil/repository/revisions/c76d6e50ba6466403457371ab8416b0600af4a77

and related bug:
https://bugs.kde.org/show_bug.cgi?id=329411

(added a comment to upstream bug too)

Comment 11 Fedora Update System 2014-07-09 02:28:48 UTC
Package libbluedevil-2.0-0.9.rc1.fc20, bluedevil-2.0.0-0.13.36f0438agit20140630.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libbluedevil-2.0-0.9.rc1.fc20 bluedevil-2.0.0-0.13.36f0438agit20140630.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-7944/libbluedevil-2.0-0.9.rc1.fc20,bluedevil-2.0.0-0.13.36f0438agit20140630.fc20
then log in and leave karma (feedback).

Comment 12 Stan Trzmiel 2014-07-09 13:46:13 UTC
A bit better (ie bluetooth is up on startup), but shuldn't bluedevil report BT adapter present even if it (the adapter) is powered off?

Comment 13 Rex Dieter 2014-07-09 14:53:14 UTC
It should behave that way now.

Comment 17 Fedora Update System 2014-07-23 03:00:57 UTC
libbluedevil-2.0-0.9.rc1.fc20, bluedevil-2.0.0-0.13.36f0438agit20140630.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.