Bug 111462 - Installer crashed modifying partition information
Installer crashed modifying partition information
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2003-12-03 17:55 EST by David Kaelbling
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-02-01 17:38:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Ananconda dump log (53.50 KB, text/plain)
2003-12-03 17:56 EST, David Kaelbling
no flags Details
syslog (8.17 KB, text/plain)
2003-12-03 17:57 EST, David Kaelbling
no flags Details

  None (edit)
Description David Kaelbling 2003-12-03 17:55:40 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030922

Description of problem:
Installing Redhat Enterprise Linux AS v3 on a PowerSpec 8192 system,
the installer crashed while I was attempting to modify the proposed
disk partition information.  It said:

Traceback (most recent call last):
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1033, in editCb
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1096, in
    raise RuntimeError, ("Returning partitions to state "

RuntimeError: Returning partitions to state prior to edit failed

I will attach the files it dumped to floppy.

Version-Release number of selected component (if applicable):

How reproducible:
Didn't try

Additional info:
Comment 1 David Kaelbling 2003-12-03 17:56:43 EST
Created attachment 96325 [details]
Ananconda dump log
Comment 2 David Kaelbling 2003-12-03 17:57:29 EST
Created attachment 96326 [details]
Comment 3 Jeremy Katz 2003-12-03 18:03:22 EST
Is this reproducible?  What did you previously have on the system? 
What change were you making at the time of the traceback?
Comment 4 David Kaelbling 2003-12-04 10:43:59 EST
I was not able to reproduce this, although that may be because I 
don't recall exactly what steps I was going through.  After the
reboot I tried again (this time leaving out some of the intermediate
fiddling with the partition table, since I had a better idea what
end result I wanted), and it worked.

My system used to dual-boot Windows XP and RedHat Linux 9.  The
existing Linux partitions were /boot, /, and swap.  I started
resizing the / partition (using PartitionMagic 8.0), but cancelled
the operation while it was moving still data.  This probably trashed
the existing file systems, but should not have harmed the disk
partition table.  I then booted off the AS v3 CDs, selected 
"automatic partitioning" telling it to erase all the existing Linux
partitions, and was tweaking the results.  The manual changes were 
to split the large '/' partition into three parts ('/', '/opt', and
'/home').  I believe the crash occurred while I was shrinking one 
of the new partitions to make space for another.

If it matters I get persistent warnings that the partitions are not
aligned properly and may not boot on older systems, but I ignore
them because my BIOS doesn't seem to have a problem.

The system disk is ~120G, currently split like this:
    Disk geometry for /dev/hda: 0.000-114498.562 megabytes
Disk label type: msdos
Minor    Start       End     Type      Filesystem  Flags
2          0.031     39.221  primary   fat32       hidden
1         39.252  14496.152  primary   ntfs        boot
3      14496.152  14598.127  primary   ext3
4      14598.127 114494.501  extended              lba
5      14598.158  30984.741  logical   ext3
6      30984.772  47371.354  logical   ext3
7      47371.386 113466.906  logical   ext3
8     113466.938 114494.501  logical   linux-swap
Comment 5 Jeremy Katz 2005-02-01 17:38:46 EST
This should be fixed in CVS now.

Note You need to log in before you can comment on or make changes to this bug.