Bug 1114673 - missing mono 2.10.8 packages
Summary: missing mono 2.10.8 packages
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: mono
Version: el6
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Xavier Lamien
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-06-30 15:25 UTC by Paul Stauffer
Modified: 2014-07-26 02:34 UTC (History)
3 users (show)

Fixed In Version: mono-2.10.8-4.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-26 02:34:54 UTC
Type: Bug


Attachments (Terms of Use)

Description Paul Stauffer 2014-06-30 15:25:09 UTC
With the recent release of mono 2.10.8 to EPEL for EL6, several subpackages appear to be missing that were previously available.  Systems with those packages installed are now unable to install updates due to broken dependencies.

The missing subpackages include mono-data-firebird, mono-data-sybase, and mono-jscript.  It is possible there are others missing as well.

Note also that several 2.10.8 packages now lack Provides that they used to offer.  It's not immediately clear if that in itself is another error, or if the missing updated packages will no longer require those features. See yum output below for a few examples.

Running yum update now returns the following:

Resolving Dependencies
--> Running transaction check
---> Package libgdiplus.x86_64 0:2.4.2-3.el6 will be updated
---> Package libgdiplus.x86_64 0:2.10-1.el6 will be an update
---> Package mono-core.x86_64 0:2.4.3.1-4.el6 will be updated
--> Processing Dependency: mono(System) = 1.0.5000.0 for package: mono-data-sybase-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(System) = 1.0.5000.0 for package: mono-data-firebird-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(System) = 1.0.5000.0 for package: mono-jscript-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(System.Drawing) = 1.0.5000.0 for package: mono-data-firebird-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(mscorlib) = 1.0.5000.0 for package: mono-data-sybase-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(mscorlib) = 1.0.5000.0 for package: mono-data-firebird-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(mscorlib) = 1.0.5000.0 for package: mono-jscript-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono-core = 2.4.3.1-4.el6 for package: mono-data-sybase-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono-core = 2.4.3.1-4.el6 for package: mono-data-firebird-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono-core = 2.4.3.1-4.el6 for package: mono-jscript-2.4.3.1-4.el6.x86_64
---> Package mono-core.x86_64 0:2.10.8-2.el6 will be an update
---> Package mono-data.x86_64 0:2.4.3.1-4.el6 will be updated
--> Processing Dependency: mono(Mono.Data.Tds) = 1.0.5000.0 for package: mono-data-sybase-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(System.Data) = 1.0.5000.0 for package: mono-data-sybase-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(System.Data) = 1.0.5000.0 for package: mono-data-firebird-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(System.EnterpriseServices) = 1.0.5000.0 for package: mono-data-sybase-2.4.3.1-4.el6.x86_64
---> Package mono-data.x86_64 0:2.10.8-2.el6 will be an update
---> Package mono-data-oracle.x86_64 0:2.4.3.1-4.el6 will be updated
---> Package mono-data-oracle.x86_64 0:2.10.8-2.el6 will be an update
---> Package mono-data-postgresql.x86_64 0:2.4.3.1-4.el6 will be updated
---> Package mono-data-postgresql.x86_64 0:2.10.8-2.el6 will be an update
---> Package mono-data-sqlite.x86_64 0:2.4.3.1-4.el6 will be updated
---> Package mono-data-sqlite.x86_64 0:2.10.8-2.el6 will be an update
---> Package mono-devel.x86_64 0:2.4.3.1-4.el6 will be updated
---> Package mono-devel.x86_64 0:2.10.8-2.el6 will be an update
--> Processing Dependency: mono(monodoc) = 1.0.0.0 for package: mono-devel-2.10.8-2.el6.x86_64
---> Package mono-extras.x86_64 0:2.4.3.1-4.el6 will be updated
--> Processing Dependency: mono(Microsoft.Vsa) = 7.0.5000.0 for package: mono-jscript-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(Microsoft.Vsa) = 8.0.0.0 for package: mono-jscript-2.4.3.1-4.el6.x86_64
---> Package mono-extras.x86_64 0:2.10.8-2.el6 will be an update
---> Package mono-wcf.x86_64 0:2.4.3.1-4.el6 will be updated
---> Package mono-wcf.x86_64 0:2.10.8-2.el6 will be an update
---> Package mono-web.x86_64 0:2.4.3.1-4.el6 will be updated
---> Package mono-web.x86_64 0:2.10.8-2.el6 will be an update
---> Package mono-winforms.x86_64 0:2.4.3.1-4.el6 will be updated
---> Package mono-winforms.x86_64 0:2.10.8-2.el6 will be an update
--> Running transaction check
---> Package mono-core.x86_64 0:2.4.3.1-4.el6 will be updated
--> Processing Dependency: mono(System) = 1.0.5000.0 for package: mono-data-sybase-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(System) = 1.0.5000.0 for package: mono-data-firebird-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(System) = 1.0.5000.0 for package: mono-jscript-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(System.Drawing) = 1.0.5000.0 for package: mono-data-firebird-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(mscorlib) = 1.0.5000.0 for package: mono-data-sybase-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(mscorlib) = 1.0.5000.0 for package: mono-data-firebird-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(mscorlib) = 1.0.5000.0 for package: mono-jscript-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono-core = 2.4.3.1-4.el6 for package: mono-data-sybase-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono-core = 2.4.3.1-4.el6 for package: mono-data-firebird-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono-core = 2.4.3.1-4.el6 for package: mono-jscript-2.4.3.1-4.el6.x86_64
---> Package mono-data.x86_64 0:2.4.3.1-4.el6 will be updated
--> Processing Dependency: mono(Mono.Data.Tds) = 1.0.5000.0 for package: mono-data-sybase-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(System.Data) = 1.0.5000.0 for package: mono-data-sybase-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(System.Data) = 1.0.5000.0 for package: mono-data-firebird-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(System.EnterpriseServices) = 1.0.5000.0 for package: mono-data-sybase-2.4.3.1-4.el6.x86_64
---> Package mono-extras.x86_64 0:2.4.3.1-4.el6 will be updated
--> Processing Dependency: mono(Microsoft.Vsa) = 7.0.5000.0 for package: mono-jscript-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(Microsoft.Vsa) = 8.0.0.0 for package: mono-jscript-2.4.3.1-4.el6.x86_64
---> Package monodoc.x86_64 0:2.10.8-2.el6 will be installed
--> Finished Dependency Resolution
Error: Package: mono-jscript-2.4.3.1-4.el6.x86_64 (@epel/6.2)
           Requires: mono(Microsoft.Vsa) = 7.0.5000.0
           Removing: mono-extras-2.4.3.1-4.el6.x86_64 (@epel/6.2)
               mono(Microsoft.Vsa) = 7.0.5000.0
               mono(Microsoft.Vsa) = 8.0.0.0
           Updated By: mono-extras-2.10.8-2.el6.x86_64 (epel)
               Not found
Error: Package: mono-jscript-2.4.3.1-4.el6.x86_64 (@epel/6.2)
           Requires: mono(mscorlib) = 1.0.5000.0
           Removing: mono-core-2.4.3.1-4.el6.x86_64 (@epel/6.2)
               mono(mscorlib) = 1.0.5000.0
               mono(mscorlib) = 2.0.0.0
           Updated By: mono-core-2.10.8-2.el6.x86_64 (epel)
               mono(mscorlib) = 4.0.0.0
               mono(mscorlib) = 2.0.0.0
Error: Package: mono-data-firebird-2.4.3.1-4.el6.x86_64 (@epel/6.2)
           Requires: mono-core = 2.4.3.1-4.el6
           Removing: mono-core-2.4.3.1-4.el6.x86_64 (@epel/6.2)
               mono-core = 2.4.3.1-4.el6
           Updated By: mono-core-2.10.8-2.el6.x86_64 (epel)
               mono-core = 2.10.8-2.el6
Error: Package: mono-data-sybase-2.4.3.1-4.el6.x86_64 (@epel/6.2)
           Requires: mono(Mono.Data.Tds) = 1.0.5000.0
           Removing: mono-data-2.4.3.1-4.el6.x86_64 (@epel/6.2)
               mono(Mono.Data.Tds) = 1.0.5000.0
               mono(Mono.Data.Tds) = 2.0.0.0
           Updated By: mono-data-2.10.8-2.el6.x86_64 (epel)
               mono(Mono.Data.Tds) = 4.0.0.0
               mono(Mono.Data.Tds) = 2.0.0.0
           Available: mono-core-2.10.8-2.el6.i686 (epel)
               mono(Mono.Data.Tds) = 4.0.0.0
               mono(Mono.Data.Tds) = 2.0.0.0
           Removing: mono-core-2.4.3.1-4.el6.x86_64 (@epel/6.2)
               Not found
           Updated By: mono-core-2.10.8-2.el6.x86_64 (epel)
               mono(Mono.Data.Tds) = 4.0.0.0
               mono(Mono.Data.Tds) = 2.0.0.0
Error: Package: mono-data-sybase-2.4.3.1-4.el6.x86_64 (@epel/6.2)
           Requires: mono(System) = 1.0.5000.0
           Removing: mono-core-2.4.3.1-4.el6.x86_64 (@epel/6.2)
               mono(System) = 1.0.5000.0
               mono(System) = 2.0.0.0
           Updated By: mono-core-2.10.8-2.el6.x86_64 (epel)
               mono(System) = 4.0.0.0
               mono(System) = 2.0.0.0
Error: Package: mono-data-firebird-2.4.3.1-4.el6.x86_64 (@epel/6.2)
           Requires: mono(System) = 1.0.5000.0
           Removing: mono-core-2.4.3.1-4.el6.x86_64 (@epel/6.2)
               mono(System) = 1.0.5000.0
               mono(System) = 2.0.0.0
           Updated By: mono-core-2.10.8-2.el6.x86_64 (epel)
               mono(System) = 4.0.0.0
               mono(System) = 2.0.0.0
Error: Package: mono-data-sybase-2.4.3.1-4.el6.x86_64 (@epel/6.2)
           Requires: mono-core = 2.4.3.1-4.el6
           Removing: mono-core-2.4.3.1-4.el6.x86_64 (@epel/6.2)
               mono-core = 2.4.3.1-4.el6
           Updated By: mono-core-2.10.8-2.el6.x86_64 (epel)
               mono-core = 2.10.8-2.el6
Error: Package: mono-data-sybase-2.4.3.1-4.el6.x86_64 (@epel/6.2)
           Requires: mono(System.Data) = 1.0.5000.0
           Removing: mono-data-2.4.3.1-4.el6.x86_64 (@epel/6.2)
               mono(System.Data) = 1.0.5000.0
               mono(System.Data) = 2.0.0.0
           Updated By: mono-data-2.10.8-2.el6.x86_64 (epel)
               Not found
           Available: mono-core-2.10.8-2.el6.i686 (epel)
               mono(System.Data) = 4.0.0.0
               mono(System.Data) = 2.0.0.0
           Removing: mono-core-2.4.3.1-4.el6.x86_64 (@epel/6.2)
               Not found
           Updated By: mono-core-2.10.8-2.el6.x86_64 (epel)
               mono(System.Data) = 4.0.0.0
               mono(System.Data) = 2.0.0.0
Error: Package: mono-jscript-2.4.3.1-4.el6.x86_64 (@epel/6.2)
           Requires: mono-core = 2.4.3.1-4.el6
           Removing: mono-core-2.4.3.1-4.el6.x86_64 (@epel/6.2)
               mono-core = 2.4.3.1-4.el6
           Updated By: mono-core-2.10.8-2.el6.x86_64 (epel)
               mono-core = 2.10.8-2.el6
Error: Package: mono-jscript-2.4.3.1-4.el6.x86_64 (@epel/6.2)
           Requires: mono(Microsoft.Vsa) = 8.0.0.0
           Removing: mono-extras-2.4.3.1-4.el6.x86_64 (@epel/6.2)
               mono(Microsoft.Vsa) = 7.0.5000.0
               mono(Microsoft.Vsa) = 8.0.0.0
           Updated By: mono-extras-2.10.8-2.el6.x86_64 (epel)
               Not found
Error: Package: mono-data-sybase-2.4.3.1-4.el6.x86_64 (@epel/6.2)
           Requires: mono(mscorlib) = 1.0.5000.0
           Removing: mono-core-2.4.3.1-4.el6.x86_64 (@epel/6.2)
               mono(mscorlib) = 1.0.5000.0
               mono(mscorlib) = 2.0.0.0
           Updated By: mono-core-2.10.8-2.el6.x86_64 (epel)
               mono(mscorlib) = 4.0.0.0
               mono(mscorlib) = 2.0.0.0
Error: Package: mono-data-firebird-2.4.3.1-4.el6.x86_64 (@epel/6.2)
           Requires: mono(System.Data) = 1.0.5000.0
           Removing: mono-data-2.4.3.1-4.el6.x86_64 (@epel/6.2)
               mono(System.Data) = 1.0.5000.0
               mono(System.Data) = 2.0.0.0
           Updated By: mono-data-2.10.8-2.el6.x86_64 (epel)
               Not found
           Available: mono-core-2.10.8-2.el6.i686 (epel)
               mono(System.Data) = 4.0.0.0
               mono(System.Data) = 2.0.0.0
           Removing: mono-core-2.4.3.1-4.el6.x86_64 (@epel/6.2)
               Not found
           Updated By: mono-core-2.10.8-2.el6.x86_64 (epel)
               mono(System.Data) = 4.0.0.0
               mono(System.Data) = 2.0.0.0
Error: Package: mono-data-sybase-2.4.3.1-4.el6.x86_64 (@epel/6.2)
           Requires: mono(System.EnterpriseServices) = 1.0.5000.0
           Removing: mono-data-2.4.3.1-4.el6.x86_64 (@epel/6.2)
               mono(System.EnterpriseServices) = 1.0.5000.0
               mono(System.EnterpriseServices) = 2.0.0.0
           Updated By: mono-data-2.10.8-2.el6.x86_64 (epel)
               Not found
           Available: mono-core-2.10.8-2.el6.i686 (epel)
               mono(System.EnterpriseServices) = 4.0.0.0
               mono(System.EnterpriseServices) = 2.0.0.0
           Removing: mono-core-2.4.3.1-4.el6.x86_64 (@epel/6.2)
               Not found
           Updated By: mono-core-2.10.8-2.el6.x86_64 (epel)
               mono(System.EnterpriseServices) = 4.0.0.0
               mono(System.EnterpriseServices) = 2.0.0.0
Error: Package: mono-data-firebird-2.4.3.1-4.el6.x86_64 (@epel/6.2)
           Requires: mono(mscorlib) = 1.0.5000.0
           Removing: mono-core-2.4.3.1-4.el6.x86_64 (@epel/6.2)
               mono(mscorlib) = 1.0.5000.0
               mono(mscorlib) = 2.0.0.0
           Updated By: mono-core-2.10.8-2.el6.x86_64 (epel)
               mono(mscorlib) = 4.0.0.0
               mono(mscorlib) = 2.0.0.0
Error: Package: mono-jscript-2.4.3.1-4.el6.x86_64 (@epel/6.2)
           Requires: mono(System) = 1.0.5000.0
           Removing: mono-core-2.4.3.1-4.el6.x86_64 (@epel/6.2)
               mono(System) = 1.0.5000.0
               mono(System) = 2.0.0.0
           Updated By: mono-core-2.10.8-2.el6.x86_64 (epel)
               mono(System) = 4.0.0.0
               mono(System) = 2.0.0.0
Error: Package: mono-data-firebird-2.4.3.1-4.el6.x86_64 (@epel/6.2)
           Requires: mono(System.Drawing) = 1.0.5000.0
           Removing: mono-core-2.4.3.1-4.el6.x86_64 (@epel/6.2)
               mono(System.Drawing) = 1.0.5000.0
               mono(System.Drawing) = 2.0.0.0
           Updated By: mono-core-2.10.8-2.el6.x86_64 (epel)
               mono(System.Drawing) = 4.0.0.0
               mono(System.Drawing) = 2.0.0.0
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Comment 1 Claudio Rodrigo Pereyra DIaz 2014-06-30 23:19:38 UTC
mono-data-firebird
mono-data-sybase
mono-jscript

was deprecate since mono-2.8 more info in http://www.mono-project.com/Release_Notes_Mono_2.8#Removed_Libraries_and_Commands

I suggest uninstall that packages and try update again.

Comment 2 Fedora Update System 2014-07-01 07:42:56 UTC
mono-2.10.8-3.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/mono-2.10.8-3.el6

Comment 3 Fedora Update System 2014-07-01 17:06:59 UTC
Package mono-2.10.8-3.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing mono-2.10.8-3.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-1798/mono-2.10.8-3.el6
then log in and leave karma (feedback).

Comment 4 Paul Stauffer 2014-07-08 20:01:53 UTC
Sorry for the delay in testing; I just realized that my repo priorities were preventing me from seeing the updated packages in epel-testing.

I verified that manually removing those deprecated packages allows the released 2.10.8-2 updates to install.  One system I tested on also had "mono-moonlight" installed, which also needed to be removed.  Looks like that's also obsoleted by the new mono-core-2.10.8-3 (though wasn't yet in 2.10.8-2).

However when I try testing the 2.10.8-3 packages in epel-testing on another system that still has the deprecated packages installed, it seems like the obsoletes you added aren't working for some reason.  Shouldn't the obsoletes cause yum to add the removal of those obsoleted packages to the transaction? That is not happening, and the transaction still fails due to the broken dependencies for those deprecated pacakges:

# yum update --enablerepo=epel-testing --disableplugin=priorities mono-core-2.10.8-3.el6
Loaded plugins: aliases, auto-update-debuginfo, product-id, protectbase, refresh-packagekit,
              : subscription-manager
Updating Red Hat repositories.
0 packages excluded due to repository protections
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package mono-core.x86_64 0:2.4.3.1-4.el6 will be updated
--> Processing Dependency: libmono-profiler-logging.so.0()(64bit) for package: mono-devel-2.4.3.1-4.el6.x86_64
--> Processing Dependency: libmono.so.0()(64bit) for package: mono-devel-2.4.3.1-4.el6.x86_64
--> Processing Dependency: libmono.so.0(VER_1)(64bit) for package: mono-devel-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(Commons.Xml.Relaxng) = 1.0.5000.0 for package: mono-devel-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(ICSharpCode.SharpZipLib) = 0.84.0.0 for package: mono-devel-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(ICSharpCode.SharpZipLib) = 0.84.0.0 for package: mono-web-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(Mono.Cecil) = 0.6.9.0 for package: mono-devel-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(Mono.CompilerServices.SymbolWriter) = 1.0.5000.0 for package: mono-devel-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(Mono.GetOptions) = 1.0.5000.0 for package: mono-devel-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(Mono.GetOptions) = 2.0.0.0 for package: mono-devel-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(Mono.Posix) = 1.0.5000.0 for package: mono-extras-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(Mono.Posix) = 1.0.5000.0 for package: mono-devel-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(Mono.Posix) = 1.0.5000.0 for package: mono-winforms-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(Mono.Security) = 1.0.5000.0 for package: mono-devel-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(Mono.Security) = 1.0.5000.0 for package: mono-data-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(Mono.Security) = 1.0.5000.0 for package: mono-web-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(Mono.Security) = 1.0.5000.0 for package: mono-data-postgresql-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(System) = 1.0.5000.0 for package: mono-data-sybase-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(System) = 1.0.5000.0 for package: mono-winforms-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(System) = 1.0.5000.0 for package: mono-extras-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(System) = 1.0.5000.0 for package: mono-devel-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(System) = 1.0.5000.0 for package: mono-data-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(System) = 1.0.5000.0 for package: mono-web-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(System) = 1.0.5000.0 for package: mono-data-oracle-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(System) = 1.0.5000.0 for package: mono-data-firebird-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(System) = 1.0.5000.0 for package: mono-data-postgresql-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(System) = 1.0.5000.0 for package: mono-jscript-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(System.Drawing) = 1.0.5000.0 for package: mono-extras-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(System.Drawing) = 1.0.5000.0 for package: mono-data-firebird-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(System.Drawing) = 1.0.5000.0 for package: mono-winforms-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(System.Drawing) = 1.0.5000.0 for package: mono-web-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(System.Xml) = 1.0.5000.0 for package: mono-extras-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(System.Xml) = 1.0.5000.0 for package: mono-devel-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(System.Xml) = 1.0.5000.0 for package: mono-winforms-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(System.Xml) = 1.0.5000.0 for package: mono-data-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(System.Xml) = 1.0.5000.0 for package: mono-web-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(mscorlib) = 1.0.5000.0 for package: mono-data-sybase-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(mscorlib) = 1.0.5000.0 for package: mono-winforms-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(mscorlib) = 1.0.5000.0 for package: mono-extras-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(mscorlib) = 1.0.5000.0 for package: mono-devel-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(mscorlib) = 1.0.5000.0 for package: mono-data-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(mscorlib) = 1.0.5000.0 for package: mono-web-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(mscorlib) = 1.0.5000.0 for package: mono-data-oracle-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(mscorlib) = 1.0.5000.0 for package: mono-data-firebird-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(mscorlib) = 1.0.5000.0 for package: mono-data-postgresql-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(mscorlib) = 1.0.5000.0 for package: mono-data-sqlite-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(mscorlib) = 1.0.5000.0 for package: mono-jscript-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono-core = 2.4.3.1-4.el6 for package: mono-data-sybase-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono-core = 2.4.3.1-4.el6 for package: mono-web-devel-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono-core = 2.4.3.1-4.el6 for package: mono-winforms-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono-core = 2.4.3.1-4.el6 for package: mono-data-oracle-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono-core = 2.4.3.1-4.el6 for package: mono-wcf-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono-core = 2.4.3.1-4.el6 for package: mono-devel-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono-core = 2.4.3.1-4.el6 for package: mono-data-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono-core = 2.4.3.1-4.el6 for package: mono-web-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono-core = 2.4.3.1-4.el6 for package: mono-extras-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono-core = 2.4.3.1-4.el6 for package: mono-data-firebird-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono-core = 2.4.3.1-4.el6 for package: mono-data-postgresql-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono-core = 2.4.3.1-4.el6 for package: mono-data-sqlite-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono-core = 2.4.3.1-4.el6 for package: mono-jscript-2.4.3.1-4.el6.x86_64
---> Package mono-core.x86_64 0:2.10.8-3.el6 will be an update
--> Running transaction check
---> Package mono-core.x86_64 0:2.4.3.1-4.el6 will be updated
--> Processing Dependency: mono(System) = 1.0.5000.0 for package: mono-data-sybase-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(System) = 1.0.5000.0 for package: mono-data-firebird-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(System) = 1.0.5000.0 for package: mono-jscript-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(System.Drawing) = 1.0.5000.0 for package: mono-data-firebird-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(mscorlib) = 1.0.5000.0 for package: mono-data-sybase-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(mscorlib) = 1.0.5000.0 for package: mono-data-firebird-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(mscorlib) = 1.0.5000.0 for package: mono-jscript-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono-core = 2.4.3.1-4.el6 for package: mono-data-sybase-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono-core = 2.4.3.1-4.el6 for package: mono-data-firebird-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono-core = 2.4.3.1-4.el6 for package: mono-jscript-2.4.3.1-4.el6.x86_64
---> Package mono-data.x86_64 0:2.4.3.1-4.el6 will be updated
--> Processing Dependency: mono(Mono.Data.Tds) = 1.0.5000.0 for package: mono-data-sybase-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(System.Data) = 1.0.5000.0 for package: mono-data-sybase-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(System.Data) = 1.0.5000.0 for package: mono-data-firebird-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(System.EnterpriseServices) = 1.0.5000.0 for package: mono-data-sybase-2.4.3.1-4.el6.x86_64
---> Package mono-data.x86_64 0:2.10.8-3.el6 will be an update
---> Package mono-data-oracle.x86_64 0:2.4.3.1-4.el6 will be updated
---> Package mono-data-oracle.x86_64 0:2.10.8-3.el6 will be an update
---> Package mono-data-postgresql.x86_64 0:2.4.3.1-4.el6 will be updated
---> Package mono-data-postgresql.x86_64 0:2.10.8-3.el6 will be an update
---> Package mono-data-sqlite.x86_64 0:2.4.3.1-4.el6 will be updated
---> Package mono-data-sqlite.x86_64 0:2.10.8-3.el6 will be an update
---> Package mono-devel.x86_64 0:2.4.3.1-4.el6 will be updated
---> Package mono-devel.x86_64 0:2.10.8-3.el6 will be an update
--> Processing Dependency: mono(monodoc) = 1.0.0.0 for package: mono-devel-2.10.8-3.el6.x86_64
---> Package mono-extras.x86_64 0:2.4.3.1-4.el6 will be updated
--> Processing Dependency: mono(Microsoft.Vsa) = 7.0.5000.0 for package: mono-jscript-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(Microsoft.Vsa) = 8.0.0.0 for package: mono-jscript-2.4.3.1-4.el6.x86_64
---> Package mono-extras.x86_64 0:2.10.8-3.el6 will be an update
---> Package mono-wcf.x86_64 0:2.4.3.1-4.el6 will be updated
---> Package mono-wcf.x86_64 0:2.10.8-3.el6 will be an update
---> Package mono-web.x86_64 0:2.4.3.1-4.el6 will be updated
---> Package mono-web.x86_64 0:2.10.8-3.el6 will be an update
---> Package mono-web-devel.x86_64 0:2.4.3.1-4.el6 will be updated
---> Package mono-web-devel.x86_64 0:2.10.8-3.el6 will be an update
---> Package mono-winforms.x86_64 0:2.4.3.1-4.el6 will be updated
---> Package mono-winforms.x86_64 0:2.10.8-3.el6 will be an update
--> Running transaction check
---> Package mono-core.x86_64 0:2.4.3.1-4.el6 will be updated
--> Processing Dependency: mono(System) = 1.0.5000.0 for package: mono-data-sybase-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(System) = 1.0.5000.0 for package: mono-data-firebird-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(System) = 1.0.5000.0 for package: mono-jscript-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(System.Drawing) = 1.0.5000.0 for package: mono-data-firebird-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(mscorlib) = 1.0.5000.0 for package: mono-data-sybase-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(mscorlib) = 1.0.5000.0 for package: mono-data-firebird-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(mscorlib) = 1.0.5000.0 for package: mono-jscript-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono-core = 2.4.3.1-4.el6 for package: mono-data-sybase-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono-core = 2.4.3.1-4.el6 for package: mono-data-firebird-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono-core = 2.4.3.1-4.el6 for package: mono-jscript-2.4.3.1-4.el6.x86_64
---> Package mono-data.x86_64 0:2.4.3.1-4.el6 will be updated
--> Processing Dependency: mono(Mono.Data.Tds) = 1.0.5000.0 for package: mono-data-sybase-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(System.Data) = 1.0.5000.0 for package: mono-data-sybase-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(System.Data) = 1.0.5000.0 for package: mono-data-firebird-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(System.EnterpriseServices) = 1.0.5000.0 for package: mono-data-sybase-2.4.3.1-4.el6.x86_64
---> Package mono-extras.x86_64 0:2.4.3.1-4.el6 will be updated
--> Processing Dependency: mono(Microsoft.Vsa) = 7.0.5000.0 for package: mono-jscript-2.4.3.1-4.el6.x86_64
--> Processing Dependency: mono(Microsoft.Vsa) = 8.0.0.0 for package: mono-jscript-2.4.3.1-4.el6.x86_64
---> Package monodoc.x86_64 0:2.10.8-3.el6 will be installed
--> Finished Dependency Resolution
Error: Package: mono-data-firebird-2.4.3.1-4.el6.x86_64 (@epel/6.2)
           Requires: mono(System.Drawing) = 1.0.5000.0
           Removing: mono-core-2.4.3.1-4.el6.x86_64 (@epel/6.2)
               mono(System.Drawing) = 1.0.5000.0
               mono(System.Drawing) = 2.0.0.0
           Updated By: mono-core-2.10.8-3.el6.x86_64 (epel-testing)
               mono(System.Drawing) = 4.0.0.0
               mono(System.Drawing) = 2.0.0.0
           Available: mono-core-2.10.8-2.el6.i686 (epel)
               mono(System.Drawing) = 4.0.0.0
               mono(System.Drawing) = 2.0.0.0
Error: Package: mono-data-firebird-2.4.3.1-4.el6.x86_64 (@epel/6.2)
           Requires: mono(mscorlib) = 1.0.5000.0
           Removing: mono-core-2.4.3.1-4.el6.x86_64 (@epel/6.2)
               mono(mscorlib) = 1.0.5000.0
               mono(mscorlib) = 2.0.0.0
           Updated By: mono-core-2.10.8-3.el6.x86_64 (epel-testing)
               mono(mscorlib) = 4.0.0.0
               mono(mscorlib) = 2.0.0.0
           Available: mono-core-2.10.8-2.el6.i686 (epel)
               mono(mscorlib) = 4.0.0.0
               mono(mscorlib) = 2.0.0.0
Error: Package: mono-data-firebird-2.4.3.1-4.el6.x86_64 (@epel/6.2)
           Requires: mono(System.Data) = 1.0.5000.0
           Removing: mono-data-2.4.3.1-4.el6.x86_64 (@epel/6.2)
               mono(System.Data) = 1.0.5000.0
               mono(System.Data) = 2.0.0.0
           Updated By: mono-data-2.10.8-3.el6.x86_64 (epel-testing)
               Not found
           Available: mono-core-2.10.8-2.el6.i686 (epel)
               mono(System.Data) = 4.0.0.0
               mono(System.Data) = 2.0.0.0
           Available: mono-core-2.10.8-3.el6.i686 (epel-testing)
               mono(System.Data) = 4.0.0.0
               mono(System.Data) = 2.0.0.0
           Removing: mono-core-2.4.3.1-4.el6.x86_64 (@epel/6.2)
               Not found
           Updated By: mono-core-2.10.8-3.el6.x86_64 (epel-testing)
               mono(System.Data) = 4.0.0.0
               mono(System.Data) = 2.0.0.0
Error: Package: mono-jscript-2.4.3.1-4.el6.x86_64 (@epel/6.2)
           Requires: mono(Microsoft.Vsa) = 7.0.5000.0
           Removing: mono-extras-2.4.3.1-4.el6.x86_64 (@epel/6.2)
               mono(Microsoft.Vsa) = 7.0.5000.0
               mono(Microsoft.Vsa) = 8.0.0.0
           Updated By: mono-extras-2.10.8-3.el6.x86_64 (epel-testing)
               Not found
Error: Package: mono-jscript-2.4.3.1-4.el6.x86_64 (@epel/6.2)
           Requires: mono(mscorlib) = 1.0.5000.0
           Removing: mono-core-2.4.3.1-4.el6.x86_64 (@epel/6.2)
               mono(mscorlib) = 1.0.5000.0
               mono(mscorlib) = 2.0.0.0
           Updated By: mono-core-2.10.8-3.el6.x86_64 (epel-testing)
               mono(mscorlib) = 4.0.0.0
               mono(mscorlib) = 2.0.0.0
           Available: mono-core-2.10.8-2.el6.i686 (epel)
               mono(mscorlib) = 4.0.0.0
               mono(mscorlib) = 2.0.0.0
Error: Package: mono-data-firebird-2.4.3.1-4.el6.x86_64 (@epel/6.2)
           Requires: mono(System) = 1.0.5000.0
           Removing: mono-core-2.4.3.1-4.el6.x86_64 (@epel/6.2)
               mono(System) = 1.0.5000.0
               mono(System) = 2.0.0.0
           Updated By: mono-core-2.10.8-3.el6.x86_64 (epel-testing)
               mono(System) = 4.0.0.0
               mono(System) = 2.0.0.0
           Available: mono-core-2.10.8-2.el6.i686 (epel)
               mono(System) = 4.0.0.0
               mono(System) = 2.0.0.0
Error: Package: mono-jscript-2.4.3.1-4.el6.x86_64 (@epel/6.2)
           Requires: mono-core = 2.4.3.1-4.el6
           Removing: mono-core-2.4.3.1-4.el6.x86_64 (@epel/6.2)
               mono-core = 2.4.3.1-4.el6
           Updated By: mono-core-2.10.8-3.el6.x86_64 (epel-testing)
               mono-core = 2.10.8-3.el6
           Available: mono-core-2.10.8-2.el6.i686 (epel)
               mono-core = 2.10.8-2.el6
Error: Package: mono-data-firebird-2.4.3.1-4.el6.x86_64 (@epel/6.2)
           Requires: mono-core = 2.4.3.1-4.el6
           Removing: mono-core-2.4.3.1-4.el6.x86_64 (@epel/6.2)
               mono-core = 2.4.3.1-4.el6
           Updated By: mono-core-2.10.8-3.el6.x86_64 (epel-testing)
               mono-core = 2.10.8-3.el6
           Available: mono-core-2.10.8-2.el6.i686 (epel)
               mono-core = 2.10.8-2.el6
Error: Package: mono-data-sybase-2.4.3.1-4.el6.x86_64 (@epel/6.2)
           Requires: mono(mscorlib) = 1.0.5000.0
           Removing: mono-core-2.4.3.1-4.el6.x86_64 (@epel/6.2)
               mono(mscorlib) = 1.0.5000.0
               mono(mscorlib) = 2.0.0.0
           Updated By: mono-core-2.10.8-3.el6.x86_64 (epel-testing)
               mono(mscorlib) = 4.0.0.0
               mono(mscorlib) = 2.0.0.0
           Available: mono-core-2.10.8-2.el6.i686 (epel)
               mono(mscorlib) = 4.0.0.0
               mono(mscorlib) = 2.0.0.0
Error: Package: mono-jscript-2.4.3.1-4.el6.x86_64 (@epel/6.2)
           Requires: mono(System) = 1.0.5000.0
           Removing: mono-core-2.4.3.1-4.el6.x86_64 (@epel/6.2)
               mono(System) = 1.0.5000.0
               mono(System) = 2.0.0.0
           Updated By: mono-core-2.10.8-3.el6.x86_64 (epel-testing)
               mono(System) = 4.0.0.0
               mono(System) = 2.0.0.0
           Available: mono-core-2.10.8-2.el6.i686 (epel)
               mono(System) = 4.0.0.0
               mono(System) = 2.0.0.0
Error: Package: mono-jscript-2.4.3.1-4.el6.x86_64 (@epel/6.2)
           Requires: mono(Microsoft.Vsa) = 8.0.0.0
           Removing: mono-extras-2.4.3.1-4.el6.x86_64 (@epel/6.2)
               mono(Microsoft.Vsa) = 7.0.5000.0
               mono(Microsoft.Vsa) = 8.0.0.0
           Updated By: mono-extras-2.10.8-3.el6.x86_64 (epel-testing)
               Not found
Error: Package: mono-data-sybase-2.4.3.1-4.el6.x86_64 (@epel/6.2)
           Requires: mono(System.Data) = 1.0.5000.0
           Removing: mono-data-2.4.3.1-4.el6.x86_64 (@epel/6.2)
               mono(System.Data) = 1.0.5000.0
               mono(System.Data) = 2.0.0.0
           Updated By: mono-data-2.10.8-3.el6.x86_64 (epel-testing)
               Not found
           Available: mono-core-2.10.8-2.el6.i686 (epel)
               mono(System.Data) = 4.0.0.0
               mono(System.Data) = 2.0.0.0
           Available: mono-core-2.10.8-3.el6.i686 (epel-testing)
               mono(System.Data) = 4.0.0.0
               mono(System.Data) = 2.0.0.0
           Removing: mono-core-2.4.3.1-4.el6.x86_64 (@epel/6.2)
               Not found
           Updated By: mono-core-2.10.8-3.el6.x86_64 (epel-testing)
               mono(System.Data) = 4.0.0.0
               mono(System.Data) = 2.0.0.0
Error: Package: mono-data-sybase-2.4.3.1-4.el6.x86_64 (@epel/6.2)
           Requires: mono-core = 2.4.3.1-4.el6
           Removing: mono-core-2.4.3.1-4.el6.x86_64 (@epel/6.2)
               mono-core = 2.4.3.1-4.el6
           Updated By: mono-core-2.10.8-3.el6.x86_64 (epel-testing)
               mono-core = 2.10.8-3.el6
           Available: mono-core-2.10.8-2.el6.i686 (epel)
               mono-core = 2.10.8-2.el6
Error: Package: mono-data-sybase-2.4.3.1-4.el6.x86_64 (@epel/6.2)
           Requires: mono(System.EnterpriseServices) = 1.0.5000.0
           Removing: mono-data-2.4.3.1-4.el6.x86_64 (@epel/6.2)
               mono(System.EnterpriseServices) = 1.0.5000.0
               mono(System.EnterpriseServices) = 2.0.0.0
           Updated By: mono-data-2.10.8-3.el6.x86_64 (epel-testing)
               Not found
           Available: mono-core-2.10.8-2.el6.i686 (epel)
               mono(System.EnterpriseServices) = 4.0.0.0
               mono(System.EnterpriseServices) = 2.0.0.0
           Available: mono-core-2.10.8-3.el6.i686 (epel-testing)
               mono(System.EnterpriseServices) = 4.0.0.0
               mono(System.EnterpriseServices) = 2.0.0.0
           Removing: mono-core-2.4.3.1-4.el6.x86_64 (@epel/6.2)
               Not found
           Updated By: mono-core-2.10.8-3.el6.x86_64 (epel-testing)
               mono(System.EnterpriseServices) = 4.0.0.0
               mono(System.EnterpriseServices) = 2.0.0.0
Error: Package: mono-data-sybase-2.4.3.1-4.el6.x86_64 (@epel/6.2)
           Requires: mono(Mono.Data.Tds) = 1.0.5000.0
           Removing: mono-data-2.4.3.1-4.el6.x86_64 (@epel/6.2)
               mono(Mono.Data.Tds) = 1.0.5000.0
               mono(Mono.Data.Tds) = 2.0.0.0
           Updated By: mono-data-2.10.8-3.el6.x86_64 (epel-testing)
               mono(Mono.Data.Tds) = 4.0.0.0
               mono(Mono.Data.Tds) = 2.0.0.0
           Available: mono-core-2.10.8-2.el6.i686 (epel)
               mono(Mono.Data.Tds) = 4.0.0.0
               mono(Mono.Data.Tds) = 2.0.0.0
           Available: mono-core-2.10.8-3.el6.i686 (epel-testing)
               mono(Mono.Data.Tds) = 4.0.0.0
               mono(Mono.Data.Tds) = 2.0.0.0
           Available: mono-data-2.10.8-2.el6.x86_64 (epel)
               mono(Mono.Data.Tds) = 4.0.0.0
               mono(Mono.Data.Tds) = 2.0.0.0
           Removing: mono-core-2.4.3.1-4.el6.x86_64 (@epel/6.2)
               Not found
           Updated By: mono-core-2.10.8-3.el6.x86_64 (epel-testing)
               mono(Mono.Data.Tds) = 4.0.0.0
               mono(Mono.Data.Tds) = 2.0.0.0
Error: Package: mono-data-sybase-2.4.3.1-4.el6.x86_64 (@epel/6.2)
           Requires: mono(System) = 1.0.5000.0
           Removing: mono-core-2.4.3.1-4.el6.x86_64 (@epel/6.2)
               mono(System) = 1.0.5000.0
               mono(System) = 2.0.0.0
           Updated By: mono-core-2.10.8-3.el6.x86_64 (epel-testing)
               mono(System) = 4.0.0.0
               mono(System) = 2.0.0.0
           Available: mono-core-2.10.8-2.el6.i686 (epel)
               mono(System) = 4.0.0.0
               mono(System) = 2.0.0.0
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Comment 5 Fedora Update System 2014-07-09 06:50:01 UTC
mono-2.10.8-4.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/mono-2.10.8-4.el6

Comment 6 Paul Stauffer 2014-07-11 13:17:04 UTC
2.10.8-4 in testing successfully resolves the problem.  The obsoleted packages are cleanly removed, and all updates can install without errors.

Positive karma registered in Bodhi.

Thanks.

Comment 7 Fedora Update System 2014-07-26 02:34:54 UTC
mono-2.10.8-4.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.