Bug 1114717 - subscription-manager list --no-overlap needs a second look (both GUI and CLI)
Summary: subscription-manager list --no-overlap needs a second look (both GUI and CLI)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 6.6
Assignee: Bryan Kearney
QA Contact: John Sefler
URL:
Whiteboard:
Depends On: 1022622
Blocks: rhsm-rhel66
TreeView+ depends on / blocked
 
Reported: 2014-06-30 18:12 UTC by Jesus M. Rodriguez
Modified: 2014-10-14 07:47 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
no documentation required
Clone Of: 1022622
Environment:
Last Closed: 2014-10-14 07:47:31 UTC
Target Upstream Version:


Attachments (Terms of Use)
tooltip (266.01 KB, image/png)
2014-07-09 10:10 UTC, Rehana
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1384 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2014-10-14 01:27:50 UTC

Comment 1 Chris Snyder 2014-07-03 17:58:37 UTC
Should be in as of commit: 731d308f097129454e3d066807d41fb6aa6bab95

Comment 3 Rehana 2014-07-09 10:10:03 UTC
Retested on,

subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 0.9.21-1
subscription management rules: 5.11
subscription-manager: 1.12.7-1.el6
python-rhsm: 1.12.4-1.el6

To demonstrate that the fix is now working as expected (bug Description), i have used the same set of installed products from the TESTDATA

1.Register machine to candlepin
#subscription-manager register
Username: testuser1
Password: 
Organization: admin
The system has been registered with ID: 8c177a61-90f2-4b2f-beb3-abee633e36df 

2.Disable auto-attach
# subscription-manager auto-attach --disable
Auto-attach preference: disabled

3.listing subscription which provides subscription only for 1 product "Awesome OS Server Bits"
# subscription-manager list --avail --match-installed | grep "awesomeos-virt-4" -B2 -A10
Subscription Name: Awesome OS with up to 4 virtual guests
Provides:          Awesome OS Server Bits
SKU:               awesomeos-virt-4
Contract:          0
Pool ID:           8ac6a362470f944701470f9548c614a0
Available:         5
Suggested:         1
Service Level:     
Service Type:      
Subscription Type: Multi-Entitleable
Ends:              07/06/2015
System Type:       Physical

4.Attached subscription
# subscription-manager attach --pool 8ac6a362470f944701470f9548c614a0
Successfully attached a subscription for: Awesome OS with up to 4 virtual guests

5.Installed product status after attaching the subscription
# subscription-manager list --installed | egrep '(Status:|Product Name:)'
Product Name:   Shared Storage Bits
Status:         Not Subscribed
Product Name:   Management Bits
Status:         Not Subscribed
Product Name:   Large File Support Bits
Status:         Not Subscribed
Product Name:   Load Balancing Bits
Status:         Not Subscribed
Product Name:   Awesome OS Server Bits
Status:         Subscribed  ---->> subscribed product

6.# subscription-manager list --available --match-installed --no-overlap 

Observed that now this ^^ command list "bundled" subscriptions,even though one of the provided product is already in 'subscribed' status

# subscription-manager list --available --match-installed --no-overlap
+-------------------------------------------+
    Available Subscriptions
+-------------------------------------------+
Subscription Name: Awesome OS Server Bundled
Provides:          Management Bits
                   Load Balancing Bits
                   Shared Storage Bits
                   Clustering Bits
                   Awesome OS Server Bits
                   Large File Support Bits
SKU:               awesomeos-server
Contract:          1
Pool ID:           8ac6a362470f944701470f9539fe0704
Available:         10
Suggested:         1
Service Level:     Premium
Service Type:      Level 3
Subscription Type: Standard
Ends:              07/06/2015
System Type:       Physical

Subscription Name: Awesome OS Server Bundled (2 Sockets, Standard Support)
Provides:          Management Bits
                   Load Balancing Bits
                   Shared Storage Bits
                   Clustering Bits
                   Awesome OS Server Bits
                   Large File Support Bits
SKU:               awesomeos-server-2-socket-std
Contract:          1
Pool ID:           8ac6a362470f944701470f953f2d0be5
Available:         10
Suggested:         1
Service Level:     Standard
Service Type:      L1-L3
Subscription Type: Standard
Ends:              07/06/2015
System Type:       Physical

Subscription Name: Awesome OS Server Bundled
Provides:          Management Bits
                   Load Balancing Bits
                   Shared Storage Bits
                   Clustering Bits
                   Awesome OS Server Bits
                   Large File Support Bits
SKU:               awesomeos-server
Contract:          0
Pool ID:           8ac6a362470f944701470f9538c20634
Available:         4
Suggested:         1
Service Level:     Premium
Service Type:      Level 3
Subscription Type: Standard
Ends:              07/06/2015
System Type:       Physical

Subscription Name: Awesome OS Server Bundled (2 Sockets, Standard Support)
Provides:          Management Bits
                   Load Balancing Bits
                   Shared Storage Bits
                   Clustering Bits
                   Awesome OS Server Bits
                   Large File Support Bits
SKU:               awesomeos-server-2-socket-std
Contract:          0
Pool ID:           8ac6a362470f944701470f953fed0caa
Available:         5
Suggested:         1
Service Level:     Standard
Service Type:      L1-L3
Subscription Type: Standard
Ends:              07/06/2015
System Type:       Physical

7.Attach the Bundled subscription , to make the system fully subscribed

# subscription-manager attach --pool 8ac6a362470f944701470f953fed0caa
Successfully attached a subscription for: Awesome OS Server Bundled (2 Sockets, Standard Support)


8.# subscription-manager status
+-------------------------------------------+
   System Status Details
+-------------------------------------------+
Overall Status: Current


9.confirming that now executing 'sub-man list --available --no-overlap --match-installed' does not list any subscriptions


# subscription-manager list --available --no-overlap --match-installed
No available subscription pools to list


ON GUI:

Tested the same on GUI, observed the same expected behaviour on GUI as well

tool tip message on GUI was updated as mentioned in the bug description

Only show subscriptions that: provide products that are not already covered
Tool Tip: Hide subscriptions whose provided products have a Subscribed status (PFA: tooltip.png)

conclusion:

Above mentioned test result demonstrated that the feature is working as expected .Hence marking this bug to "Verified"

Comment 4 Rehana 2014-07-09 10:10:34 UTC
Created attachment 916697 [details]
tooltip

Comment 6 errata-xmlrpc 2014-10-14 07:47:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1384.html


Note You need to log in before you can comment on or make changes to this bug.