Bug 111476 - XFree86 update breaks ATI Radeon 7000 setup
XFree86 update breaks ATI Radeon 7000 setup
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2003-12-04 05:21 EST by Piero Calucci
Modified: 2007-04-18 12:59 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-10-12 09:11:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
lspci -vv and cat /var/log/XFree86.0.log (54.72 KB, text/plain)
2003-12-16 09:28 EST, Thomas J. Baker
no flags Details

  None (edit)
Description Piero Calucci 2003-12-04 05:21:37 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.11 (X11; Linux i686; U;) Gecko/20030417

Description of problem:
ATI Radeon 7000 on athlon

After updating XFree to 4.3.0-2.90.43 

1) the screen goes 640x480. I mean: desktop is still 1024x768 or
whatever, but I can see only 640x480 -- nice that going with the mouse
cursor beyond edges pans the visible portion of the desktop.
redhat-config-xfree86 cannot solve

2) redhat-config-xfree86 is unable to probe monitor and/or read any
monitor information (monitor is a NEC v72)

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. update XFree to 4.3.0-2.90.43

Actual Results:  can see only 640x480 at a time

cannot probe monitor/read monitor info

Expected Results:  whole desktop visible

Additional info:

reverting to XFree86-4.3.0-2 solves the issue

# kudzu -p 

<blahblah />

class: VIDEO
bus: PCI
detached: 0
driver: Card:ATI Radeon 7000
desc: "ATI|Radeon VE QY"
vendorId: 1002
deviceId: 5159
subVendorId: 174b
subDeviceId: 7141
pciType: 1

# rpm -q kernel
Comment 1 Thomas J. Baker 2003-12-16 09:28:06 EST
Created attachment 96555 [details]
lspci -vv and cat /var/log/XFree86.0.log
Comment 2 Thomas J. Baker 2003-12-16 09:28:32 EST
I'm experiencing this bug also. See above attachment for details.
Comment 3 Thomas J. Baker 2004-03-08 15:00:04 EST
This problem persists with XFree86-4.3.0-2.90.55. What other
information do you need?
Comment 4 Trevor Cordes 2004-03-28 01:59:54 EST
A system I'm setting up also has this problem (glad to find I'm not
the only one!).  We're using a brand new Sapphire Radeon 7000 LITE DDR
32MB card.  We've tried everything to get above 640 but no go.  The
log says all modes except 640x480 are unknown.
Comment 5 Ali Kwan 2004-04-21 17:29:54 EDT
In Fedora core 2 test2 (in fact any install since red hat 9 XFree 4.3.0-2) can only get 640 x 
480 resolution to fit on 19 inch Sharp LCD LL-T19D1-B. All other resolutions become 
larger than the screen and moving the mouse to the edges of the screen will make it scroll 
to the offscreen areas. I've checked my X config and all the proper options are there and 
I've tried them all. Also CTRL + ALT +/- does nothing. Could someone please fix this 
before Fedora Core 2 Final is released. I would really like to upgrade but not lke this. (P.S. 
both my video card and monitor are probed properly during install). Below is a copy of 
XF86Config that works in Red Hat 9 XFree 4.3.0-2 ONLY anything higher has the same 
result, even though the config is identical---Any other solutions in the meantime?
# XFree86 4 configuration created by pyxf86config

Section "ServerLayout"
    Identifier     "Default Layout"
    Screen      0  "Screen0" 0 0
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "DevInputMice" "AlwaysCore"

Section "Files"
# RgbPath is the location of the RGB database.  Note, this is the name of the 
# file minus the extension (like ".txt" or ".db").  There is normally
# no need to change the default.

# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.

    RgbPath      "/usr/X11R6/lib/X11/rgb"
    FontPath     "unix/:7100"

Section "Module"
    Load  "dbe"
    Load  "extmod"
    Load  "fbdevhw"
    Load  "glx"
    Load  "record"
    Load  "freetype"
    Load  "type1"
    Load  "dri"

Section "InputDevice"
# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
#   Option  "Xleds"     "1 2 3"

# To disable the XKEYBOARD extension, uncomment XkbDisable.
#   Option  "XkbDisable"

# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults).  For example, for a non-U.S.
# keyboard, you will probably want to use:
#   Option  "XkbModel"  "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
#   Option  "XkbModel"  "microsoft"
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
#   Option  "XkbLayout" "de"
# or:
#   Option  "XkbLayout" "de"
#   Option  "XkbVariant"    "nodeadkeys"
# If you'd like to switch the positions of your capslock and
# control keys, use:
#   Option  "XkbOptions"    "ctrl:swapcaps"
# Or if you just want both to be control, use:
#   Option  "XkbOptions"    "ctrl:nocaps"
    Identifier  "Keyboard0"
    Driver      "keyboard"
    Option      "XkbRules" "xfree86"
    Option      "XkbModel" "pc105"
    Option      "XkbLayout" "us"

Section "InputDevice"
    Identifier  "Mouse0"
    Driver      "mouse"
    Option      "Protocol" "PS/2"
    Option      "Device" "/dev/psaux"
    Option      "ZAxisMapping" "4 5"
    Option      "Emulate3Buttons" "yes"

Section "InputDevice"
# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
    Identifier  "DevInputMice"
    Driver      "mouse"
    Option      "Protocol" "IMPS/2"
    Option      "Device" "/dev/input/mice"
    Option      "ZAxisMapping" "4 5"
    Option      "Emulate3Buttons" "no"

Section "Monitor"
    Identifier   "Monitor0"
    VendorName   "Monitor Vendor"
    ModelName    "LL-T19D1-B"
    DisplaySize  380    300
    HorizSync    24.0 - 81.0
    VertRefresh  56.0 - 76.0
    Option      "dpms"

Section "Device"
    Identifier  "Videocard0"
    Driver      "radeon"
    VendorName  "Videocard vendor"
    BoardName   "ATI Radeon 7000"
    VideoRam    32768

Section "Screen"
    Identifier "Screen0"
    Device     "Videocard0"
    Monitor    "Monitor0"
    DefaultDepth     24
    SubSection "Display"
        Depth     24
        Modes    "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"

Section "DRI"
    Group        0
    Mode         0666
Comment 6 Mike A. Harris 2004-10-12 09:11:00 EDT
Since this bugzilla report was filed, there have been several major
updates to the X Window System, which may resolve this issue.  Users
who have experienced this problem are encouraged to upgrade to the
latest version of Fedora Core, which can be obtained from:


If this issue turns out to still be reproduceable in the latest
version of Fedora Core, please file a bug report in the X.Org
bugzilla located at http://bugs.freedesktop.org in the "xorg"

Once you've filed your bug report to X.Org, if you paste the new
bug URL here, Red Hat will continue to track the issue in the
centralized X.Org bug tracker, and will review any bug fixes that
become available for consideration in future updates.

Note You need to log in before you can comment on or make changes to this bug.