Bug 1114785 - host.conf: "multi on" appears to be default
Summary: host.conf: "multi on" appears to be default
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: man-pages-overrides   
(Show other bugs)
Version: 6.5
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Jan Chaloupka
QA Contact: Iveta Wiedermann
URL:
Whiteboard:
Keywords: ManPageChange, Patch
Depends On:
Blocks: 1119267
TreeView+ depends on / blocked
 
Reported: 2014-07-01 02:17 UTC by Anand Vaddarapu
Modified: 2018-12-09 18:05 UTC (History)
6 users (show)

Fixed In Version: man-pages-overrides-6.6.2-1.el6
Doc Type: Bug Fix
Doc Text:
Cause: man page described incorrect default value of multi in host.conf Consequence: incorrect documentation Fix: default value of multi now describes "on" Result: updated documentation
Story Points: ---
Clone Of:
: 1131859 (view as bug list)
Environment:
Last Closed: 2014-10-14 07:27:24 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
host.conf.5 multi on by default (737 bytes, patch)
2014-07-01 12:26 UTC, Jan Chaloupka
no flags Details | Diff
host.conf.5 multi on by default (845 bytes, patch)
2014-07-02 05:33 UTC, Jan Chaloupka
no flags Details | Diff
host.conf.5 multi on by default (847 bytes, patch)
2014-07-02 09:03 UTC, Jan Chaloupka
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1382 normal SHIPPED_LIVE man-pages-overrides bug fix update 2014-10-14 01:21:54 UTC
Debian BTS 459664 None None None Never

Description Anand Vaddarapu 2014-07-01 02:17:21 UTC
Description of problem:
From host.conf man page:-

       multi  Valid values are on and off.  If set to on, the resolv+ library will  return all  valid addresses for a host that appears in the /etc/hosts file, instead of only the first.  This is off by default, as it may  cause  a  substantial performance loss at sites with large hosts files.

From RHEL 6+ that the "multi on" is set in /etc/host.conf

# cat /etc/host.conf 
multi on

cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 6.4 (Santiago)

Same behaviour is not observed in RHEL 5+

Is the default set wrongly, or just incorrectly documented?

Comment 1 Siddhesh Poyarekar 2014-07-01 11:43:30 UTC
glibc does not set or own /etc/host.conf, it only reads it.  Assigning to the right component.

Comment 2 Ondrej Vasik 2014-07-01 11:55:52 UTC
Intentional ... but performance hit is not occuring anymore - see https://bugzilla.redhat.com/show_bug.cgi?id=486461#c2 for reasoning. I recommend to change the man page instead.

Comment 3 Jan Chaloupka 2014-07-01 12:26:46 UTC
Created attachment 913738 [details]
host.conf.5 multi on by default

Comment 5 Jan Chaloupka 2014-07-02 05:33:19 UTC
Created attachment 913986 [details]
host.conf.5 multi on by default

Comment 6 Jan Chaloupka 2014-07-02 09:03:19 UTC
Created attachment 914073 [details]
host.conf.5 multi on by default

Comment 12 errata-xmlrpc 2014-10-14 07:27:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1382.html


Note You need to log in before you can comment on or make changes to this bug.