Bug 1114902 - CVE-2014-3248 facter: puppet: Ruby modules could be loaded from the current working directory [fedora-20]
Summary: CVE-2014-3248 facter: puppet: Ruby modules could be loaded from the current w...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: facter
Version: 20
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael Stahnke
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: fst_owner=jrusnack
Depends On:
Blocks: CVE-2014-3248
TreeView+ depends on / blocked
 
Reported: 2014-07-01 08:54 UTC by Murray McAllister
Modified: 2015-01-04 22:40 UTC (History)
8 users (show)

Fixed In Version: facter-1.7.6-1.fc20
Doc Type: Release Note
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-22 12:33:22 UTC
Type: ---


Attachments (Terms of Use)

Description Murray McAllister 2014-07-01 08:54:48 UTC
This is an automatically created tracking bug!  It was created to ensure
that one or more security vulnerabilities are fixed in affected versions
of Fedora.

For comments that are specific to the vulnerability please use bugs filed
against the "Security Response" product referenced in the "Blocks" field.

For more information see:
http://fedoraproject.org/wiki/Security/TrackingBugs

When creating a Bodhi update request, use the bodhi submission link noted
in the next comment(s).  This will include the bug IDs of this tracking
bug as well as the relevant top-level CVE bugs.

Please also mention the CVE IDs being fixed in the RPM changelog and the
Bodhi notes field when available.

fedora-20 tracking bug for facter: see blocks bug list for full details of the security issue(s).

[bug automatically created by: add-tracking-bugs]

Comment 1 Murray McAllister 2014-07-01 08:55:02 UTC
Use the following update submission link to create the Bodhi request for
this issue as it contains the top-level parent bug(s) as well as this
tracking bug.  This will ensure that all associated bugs get updated when
new packages are pushed to stable.

IMPORTANT: ensure that the "Close bugs when update is stable" option
remains checked.

Bodhi update submission link:
https://admin.fedoraproject.org/updates/new/?type_=security&bugs=1101346,1114902

Comment 2 Michael Stahnke 2014-10-11 05:15:52 UTC
http://koji.fedoraproject.org/koji/taskinfo?taskID=7829944 has the build.

Comment 3 Fedora Update System 2014-10-11 05:17:47 UTC
facter-1.7.6-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/facter-1.7.6-1.fc20

Comment 4 Fedora Update System 2014-10-12 05:07:43 UTC
Package facter-1.7.6-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing facter-1.7.6-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-12699/facter-1.7.6-1.fc20
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2014-11-22 12:33:22 UTC
facter-1.7.6-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.