Bug 1114955 - Add filter, weight or balance module under cluster policy failed
Summary: Add filter, weight or balance module under cluster policy failed
Keywords:
Status: CLOSED DUPLICATE of bug 1113485
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-api
Version: 3.5
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: ---
Assignee: Juan Hernández
QA Contact: Pavel Stehlik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-01 10:42 UTC by Artyom
Modified: 2014-07-01 11:35 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-01 11:35:13 UTC
oVirt Team: ---


Attachments (Terms of Use)

Description Artyom 2014-07-01 10:42:03 UTC
Description of problem:
When I trying to add new filter under cluster policy action failed

Version-Release number of selected component (if applicable):
ovirt-engine-3.5.0-0.0.master.20140629172257.git0b16ed7.el6.noarch

How reproducible:
Always

Steps to Reproduce:
1. Add new filter under user cluster policy via REST(https://engine_ip/api/schedulingpolicies/scheduling_policy_id/filters)
2. Run post request with: <filter id="id_of_one_of_available_filters"/>
3.

Actual results:
Action failed with error:
HTTP Status 500 - Bad arguments passed to public abstract org.ovirt.engine.api.model.BaseResource org.ovirt.engine.api.resource.PolicyUnitsResource.add(org.ovirt.engine.api.model.BaseResource) ( org.ovirt.engine.api.model.Filter org.ovirt.engine.api.model.Filter@20c69f3a )

Expected results:
Action success without any errors

Additional info:
The same thing also relevant for weight and balancing modules

Comment 1 Juan Hernández 2014-07-01 11:35:13 UTC
This is a duplicate of bug 1113485. As a workaround use /ovirt-engine/api instead of /api.

*** This bug has been marked as a duplicate of bug 1113485 ***


Note You need to log in before you can comment on or make changes to this bug.