Bug 1114962 - - drive-mirror with "mode":"existing" fails poorly if destination is not large enough
Summary: - drive-mirror with "mode":"existing" fails poorly if destination is not larg...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm-rhev
Version: 7.0
Hardware: x86_64
OS: All
medium
medium
Target Milestone: rc
: ---
Assignee: Jeff Cody
QA Contact: Qianqian Zhu
URL:
Whiteboard:
: 1115572 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-01 10:48 UTC by FuXiangChun
Modified: 2016-11-07 20:14 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-07 20:14:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2673 normal SHIPPED_LIVE qemu-kvm-rhev bug fix and enhancement update 2016-11-08 01:06:13 UTC

Description FuXiangChun 2014-07-01 10:48:30 UTC
Description of problem:
QE tested qemu-kvm-rhev-1.5.3-60.el7ev, it hit the same issue as 1114793 bug. so file a new bug to track this issue. I am trying to reproduce it with qmp command directly.  will update result to bz asap.

Version-Release number of selected component (if applicable):
qemu-kvm-rhev-1.5.3-60.el7ev.x86_64
3.10.0-123.4.2.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.qemu-img create -f raw base.img 10M

2.qemu-img create -f qcow2 -b base.img -o backing_fmt=raw snap1.img

3.qemu-img create -f qcow2 -b snap1.img -o backing_fmt=qcow2 snap2.img
# set up blank space to hold the copy
touch copy.img
# cp base.img copy.img 

4.xml file
<domain type='kvm'>
 <name>testvm4</name>
 <memory unit='MiB'>256</memory>
 <vcpu>1</vcpu>
<os>
<type arch='x86_64' machine='pc-i440fx-rhel7.0.0'>hvm</type>
<boot dev='hd'/>
</os>
 <devices>
   <disk type='file' device='disk'>
     <driver name='qemu' type='qcow2' cache='none'/>
     <source file='/var/lib/libvirt/images/snap2.img'/>
     <target dev='hda' bus='virtio'/>
   </disk>
   <graphics type='vnc'/>
 </devices>
</domain>

5.# check for events
virsh event testvm1 block-job --loop --timeout 10 &
pid=$!
sleep 1
# run the blockcopy
virsh blockcopy testvm1 vda --wait --verbose --raw /tmp/copy.img --reuse-external
echo job started
sleep 5
virsh blockjob testvm1 vda --abort
wait $pid

Actual results:
error: Requested operation is not valid: domain is not transient

job started
error: Requested operation is not valid: No active operation on device: drive-virtio-disk0

Expected results:

Block Copy: [  0 %]event 'block-job' for domain testvm1: Block Copy for /tmp/snap2.img ready
Block Copy: [100 %]
Now in mirroring phase
job started
event 'block-job' for domain testvm1: Block Copy for /tmp/snap2.img completed

event loop timed out
events received: 2

Additional info:

Comment 1 juzhang 2014-07-04 02:16:26 UTC
*** Bug 1115572 has been marked as a duplicate of this bug. ***

Comment 4 Ademar Reis 2015-07-29 20:46:58 UTC
(In reply to FuXiangChun from comment #0)
> Description of problem:
> QE tested qemu-kvm-rhev-1.5.3-60.el7ev, it hit the same issue as 1114793
> bug. so file a new bug to track this issue. I am trying to reproduce it with
> qmp command directly.  will update result to bz asap.

Have you tried reproducing it with QEMU only?

Comment 6 Pei Zhang 2015-12-15 09:22:25 UTC
Summary: I tested with the latest qemu, this issue seams has gone.

Versions:
qemu-kvm-rhev:qemu-kvm-rhev-2.3.0-31.el7_2.5.x86_64

Steps:
1. Same step as https://bugzilla.redhat.com/show_bug.cgi?id=1114793#c0

2. Below results are the original bug expected results.
...
Block Copy: [100 %]event 'block-job' for domain testvm1: Block Copy for /tmp/snap2.img ready
Block Copy: [100 %]
Now in mirroring phase
job started

event 'block-job' for domain testvm1: Block Copy for /tmp/snap2.img completed
event loop timed out
events received: 2

Comment 9 Qianqian Zhu 2016-08-23 07:21:23 UTC
Verified with:
qemu-kvm-rhev-2.6.0-20.el7.x86_64
qemu-img-rhev-2.6.0-20.el7.x86_64
kernel-3.10.0-491.el7.x86_64

Steps same as https://bugzilla.redhat.com/show_bug.cgi?id=1114793#c0

Results:
Block Copy: [100 %]event 'block-job' for domain testvm1: Block Copy for /tmp/snap2.img ready
Block Copy: [100 %]
Now in mirroring phase
job started

event 'block-job' for domain testvm1: Block Copy for /tmp/snap2.img completed
event loop timed out
events received: 2

Moving to VERIFIED.

Comment 11 errata-xmlrpc 2016-11-07 20:14:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2673.html


Note You need to log in before you can comment on or make changes to this bug.