Bug 111498 - subversion hook scripts have a bad shebang line
subversion hook scripts have a bad shebang line
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: subversion (Show other bugs)
1
All Linux
medium Severity low
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-04 12:13 EST by Scott Gose
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 0.35.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-11 04:53:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Gose 2003-12-04 12:13:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114 Epiphany/1.0.4

Description of problem:
The following hook scripts have a bad shebang line:

/usr/share/doc/subversion-0.32.1/tools/hook-scripts/commit-access-control.pl
/usr/share/doc/subversion-0.32.1/tools/hook-scripts/propchange-email.pl
/usr/share/doc/subversion-0.32.1/tools/hook-scripts/commit-email.pl

Their shebang line is:

#!/usr/bin/env perl -w

I believe it needs to be:

#!/usr/bin/env perl

Because when I run them as is, I get:

/usr/bin/env: perl -w: No such file or directory


Version-Release number of selected component (if applicable):
subversion-0.32.1-1

How reproducible:
Always

Steps to Reproduce:
1. /usr/share/doc/subversion-0.32.1/tools/hook-scripts/commit-email.pl
2.
3.
    

Actual Results:  /usr/bin/env: perl -w: No such file or directory

Additional info:
Comment 1 Joe Orton 2004-02-11 04:53:07 EST
This has been fixed in Raw Hide for a while, thanks for the report.

Note You need to log in before you can comment on or make changes to this bug.