Bug 1115136 - EPEL7 build of bodhi-client installs client in the wrong place
Summary: EPEL7 build of bodhi-client installs client in the wrong place
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: bodhi
Version: epel7
Hardware: All
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Luke Macken
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-01 16:28 UTC by Jonathan Billings
Modified: 2016-09-20 02:46 UTC (History)
8 users (show)

Fixed In Version: bodhi-0.9.8-4.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-27 18:44:17 UTC


Attachments (Terms of Use)

Description Jonathan Billings 2014-07-01 16:28:49 UTC
Description of problem:
When the bodhi.spec file was updated for epel7 in commit 79547df691ab5624bb0ef9cf47799b944aa06434, it added:

+%{__mkdir_p} %{buildroot}%{_bindir}/%{name}
+%{__mkdir_p} %{buildroot}%{_mandir}/man1
 %{__install} %{name}/tools/client.py %{buildroot}%{_bindir}/%{name}
+%{__install} docs/bodhi.1 %{buildroot}%{_mandir}/man1/bodhi.1

Unfortunately, that means that client.py was installed into a directory called /usr/bin/bodhi/, rather than as a file called /usr/bin/bodhi.  This means that on an installed EL7 system, the bodhi client is called /usr/bin/bodhi/client.py.

The simple solution is to change that first line to:
%{__mkdir_p} %{buildroot}%{_bindir}

Version-Release number of selected component (if applicable):
bodhi-client-0.9.8-3.el7.noarch


How reproducible:
Always

Steps to Reproduce:
1. Install 'bodhi-client' on an RHEL7 system with EPEL7 enabled
2. Try to run 'bodhi' from the command line
3.

Actual results:
No executable found.  You have to run /usr/bin/bodhi/client.py to get the correct behavior.

Expected results:
'bodhi' to behave like every other platform.

Additional info:

Comment 1 Ding-Yi Chen 2014-07-16 08:14:32 UTC
Bug reproduced with bodhi-client.noarch 0:0.9.8-3.el7

Steps to reproduce:
1. Run repoquery -ql bodhi-client


Actual:
/usr/bin/bodhi
/usr/bin/bodhi/client.py
/usr/share/man/man1/bodhi.1.gz

/usr/bin/bodhi is a directory!

Expected:
/usr/bin/bodhi
/usr/share/man/man1/bodhi.1.gz

/usr/bin/bodhi should be an executable.

Comment 2 Jens Petersen 2014-07-16 08:17:45 UTC
Would be nice to fix this before EPEL7 goes out of Beta soon.

Comment 3 Eric Smith 2014-08-30 05:21:13 UTC
Would be nice to fix this now that EPEL7 is out of beta, since this breaks "fedpkg update".

Comment 4 Mark Wielaard 2014-09-09 21:54:55 UTC
This is indeed a little confusing since fedpkg update does indeed just not work with the message /bin/sh: bodhi: command not found
Could not generate update request: Command 'bodhi --new --release f21 --file bodhi.template ...' returned non-zero exit status 127

Comment 5 Fedora Update System 2014-09-09 23:57:16 UTC
bodhi-0.9.8-4.el7 has been submitted as an update for Fedora EPEL 7.
https://admin.fedoraproject.org/updates/bodhi-0.9.8-4.el7

Comment 6 Fedora Update System 2014-09-11 20:30:00 UTC
Package bodhi-0.9.8-4.el7:
* should fix your issue,
* was pushed to the Fedora EPEL 7 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing bodhi-0.9.8-4.el7'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-2571/bodhi-0.9.8-4.el7
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2014-09-27 18:44:17 UTC
bodhi-0.9.8-4.el7 has been pushed to the Fedora EPEL 7 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 M. Scherer 2014-09-27 22:47:05 UTC
It has to be noted that the upgrade path is broken. 

Transaction check error:
  file /usr/bin/bodhi from install of bodhi-client-0.9.8-4.el7.noarch conflicts with file from package bodhi-client-0.9.8-3.el7.noarch

Comment 9 Laszlo Ersek 2014-09-29 07:40:11 UTC
(In reply to M. Scherer from comment #8)
> It has to be noted that the upgrade path is broken. 
> 
> Transaction check error:
>   file /usr/bin/bodhi from install of bodhi-client-0.9.8-4.el7.noarch
> conflicts with file from package bodhi-client-0.9.8-3.el7.noarch

+1, same here.

I could of course uninstall the old version first, but then it would remove "fedpkg" too, for dependencies, and unfortunately that would delete the "/etc/rpkg/fedpkg.conf" file too.

Comment 10 Jens Petersen 2014-10-08 08:58:17 UTC
Yeah... I think simplest workaround is to "sudo rpm -e bodhi-client --nodeps"
before yum updating.


Note You need to log in before you can comment on or make changes to this bug.