Bug 111514 - [PATCH] incorrect HighTotal field in /proc/meminfo
Summary: [PATCH] incorrect HighTotal field in /proc/meminfo
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 3.0
Hardware: ia64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anil S Keshavamurthy
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-12-04 19:53 UTC by Ken Chen
Modified: 2007-11-30 22:06 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 19:32:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
not to count boot time reserved page as totalhigh_pages (424 bytes, patch)
2003-12-04 19:57 UTC, Ken Chen
no flags Details | Diff

Description Ken Chen 2003-12-04 19:53:42 UTC
On DIG compliant platform like tiger4 machine, physical memory are 
partitioned into DMA and HIGHMEM zones.  The count_highmem_pages 
function incorrectly count all boot time reserved page as part of 
total highmem page. As a result, causing inflated highmem total 
reported in /proc/meminfo.  The LowTotal field in /proc/meminfo is 
calculated as totalram_page - totalhigh_pages.  Since total high is 
inflated, it cause total low to be under count and on some machine, 
we observed that low total is less than low free from /proc/meminfo.


Version-Release number of selected component (if applicable):
kernel-2.4.21-4.EL

How reproducible:
Always

Steps to Reproduce:
1. on any tiger4 or DIG compliant ia64 machine with large amount of 
memory
2. cat /proc/meminfo
3.
    

Actual Results:  MemTotal:     262361248 kB
MemFree:      93100976 kB
MemShared:           0 kB
Buffers:          9824 kB
Cached:          64496 kB
SwapCached:          0 kB
Active:          75872 kB
ActiveAnon:      10992 kB
ActiveCache:     64880 kB
Inact_dirty:      9440 kB
Inact_laundry:       0 kB
Inact_clean:         0 kB
Inact_target:    17056 kB
HighTotal:    260570320 kB
HighFree:     90778928 kB
LowTotal:      1790928 kB
LowFree:       2322048 kB
SwapTotal:     2040208 kB
SwapFree:      2040208 kB


Expected Results:  LowTotal to be equal or greater than LowFree field

Additional info:

Comment 1 Ken Chen 2003-12-04 19:57:12 UTC
Created attachment 96348 [details]
not to count boot time reserved page as totalhigh_pages

Comment 2 RHEL Product and Program Management 2007-10-19 19:32:28 UTC
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.


Note You need to log in before you can comment on or make changes to this bug.