Bug 111526 - CUPS crashes when using Samsung lpp drivers
CUPS crashes when using Samsung lpp drivers
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-04 16:20 EST by An. N
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-05 07:44:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description An. N 2003-12-04 16:20:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030

Description of problem:
The printer used here is Samsung ML-1710.

When using Samsung LPP drivers (1.1.1-3), one of the cups processes
crashes as seen here (excerpt from cups error_log):

D [04/Dec/2003:22:07:16 +0100] [Job 30] Caught fatal signal 11!! Aborting.
D [04/Dec/2003:22:07:16 +0100] [Job 30] Process 6420 Stack dump:
D [04/Dec/2003:22:07:16 +0100] [Job 30]
D [04/Dec/2003:22:07:16 +0100] [Job 30] lp(vfprintf+0x4811) [0x804e545]
D [04/Dec/2003:22:07:16 +0100] [Job 30] /lib/tls/libc.so.6 [0x815a18]
D [04/Dec/2003:22:07:16 +0100] [Job 30] lp(__dcgettext+0x5e1) [0x804a5c5]
D [04/Dec/2003:22:07:16 +0100] [Job 30]
/lib/tls/libc.so.6(__libc_start_main+0xf0) [0x803750]
D [04/Dec/2003:22:07:16 +0100] [Job 30] lp(setgrent+0x9d) [0x804a271]
D [04/Dec/2003:22:07:16 +0100] [Job 30]
E [04/Dec/2003:22:07:16 +0100] PID 6420 stopped with status 111!

As a result, nothing is printed. Installing the samsung drivers also
causes the redhat-config-printer program to crash upon startup (python
errors: should this be reported as a bug?).

Please see the attached files fore more information.


Version-Release number of selected component (if applicable):
cups-1.1.19-13

How reproducible:
Always

Steps to Reproduce:
1. Install Samsung LPP drivers (1.1.1-3)
2. Configure printer
3. Set cups logging to debug2
4. Try printing a page


Actual Results:  Printer did not react in any way (not even
dehibernated, so no data was sent). Errors in cups logfile (see
attached file).

Expected Results:  A nice test page... at least :)

Additional info:

Linux dhalvasdra 2.4.22-1.2115.nptl #1 Wed Oct 29 15:31:21 EST 2003
i686 athlon i386 GNU/Linux
lpp 1.1.1-3 (23 oct 2003, newest version to date), available here:
http://downloadcenter.samsung.com/content/DR/200310/20031023170000234_lpp-1.1.1-3.i386.tar.gz
standard fedora core 1 installation, original fedora glibc etc.
no changes made to cups or any other printing-related subsystem
Comment 1 Tim Waugh 2003-12-05 07:44:43 EST
This looks like what's actually crashing is the (binary only?) driver
that you added.
Comment 2 An. N 2003-12-05 08:46:58 EST
That is true, after some research I did today it appears that the
Samsung drivers seem to have some serious problems.

Note You need to log in before you can comment on or make changes to this bug.