Bug 111531 - multiple problems in the source code
multiple problems in the source code
Status: CLOSED DUPLICATE of bug 78481
Product: Fedora
Classification: Fedora
Component: xloadimage (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-04 17:09 EST by d.binderman
Modified: 2014-03-16 22:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description d.binderman 2003-12-04 17:09:43 EST
Description of problem:
I just tried to compile package xloadimage-4.1-29 from Fedora.

The compiler said

1.

sunraster.c:243: warning: too few arguments for format

The source code is

    fprintf(stderr, "%s: Unsupported Sun Rasterfile image type
(sorry)\n");

Missing string for the %s specifier.

2.

tiff.c:220: warning: too few arguments for format

The source code is

    printf("Titled \"%s\"");

Missing string for the %s specifier.

3.

tiff.c:407: warning: too few arguments for format

The source code is

      fprintf(stderr,
              "%s: Can't handle TIFF RGB images with %d samples per
pixel, sorry\n",
              info.samplesperpixel);

Missing string for the %s specifier.

I can recommend use of the -Wall compiler flag to help remove these 
obvious run time bugs.




Version-Release number of selected component (if applicable):
xloadimage-4.1-29 

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Miloslav Trmac 2004-02-06 14:24:15 EST

*** This bug has been marked as a duplicate of 78481 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:00:17 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.