Bug 1115555 - JGroups configuration files might be shadowed if the JDG infinispan-core library is provided as EAP module
Summary: JGroups configuration files might be shadowed if the JDG infinispan-core libr...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Data Grid 6
Classification: JBoss
Component: EAP modules
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ER8
: 6.4.0
Assignee: Martin Gencur
QA Contact: Martin Gencur
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-02 15:26 UTC by wfink
Modified: 2015-02-22 23:59 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously in Red Hat JBoss Data Grid, the default configuration files for JGroups were named <filename>jgroups-udp.xml</filename> and <filename>jgroups-tcp.xml</filename>. When a user provided their own configuration file with the same name, it was unexpectedly shadowed with the default one. This issue is now resolved in JBoss Data Grid 6.4. The default configuration files are now moved to the <filename class="directory">default-configs<filename> directory, renamed to <filename>default-jgroups-udp.xml</filename> and <filename>default-jgroups-tcp.xml</filename>. Additionally, if a user chooses the same name for their customized configuration files, a warning is logged.
Clone Of:
Environment:
Last Closed: 2015-01-28 13:29:45 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker ISPN-4499 0 Major Resolved Prevent shadowing user-defined jgroups configuration file 2014-12-03 13:43:48 UTC

Description wfink 2014-07-02 15:26:15 UTC
Description of problem:
If JDG is used in embedded (library) mode and the application use JDG as modules the jgroups configuration files:
  jgroups-ec2.xml         
  jgroups-tcp.xml         
  jgroups-udp.xml
which might included in the application are shadowed, the customer configuration is overriden by the JDG default files.
The problem is that these filenames are used very often in examples so there is a high risk that they are used in real applications.

This behaviour is different if the infinispan libraries are included in the application packaging instead of the module dependency.


Actual results:
If the configuration file names jgroups-ec2.xml, jgroups-tcp.xml, jgroups-udp.xml are used in an application the cluster configuration does not have any effect as it will be overriden by the default files and this causes the use of wrong IP addresses or ports for cluster communication.

Expected results:
The files should provided in the customer context should never shadowed by files included in the infinispan library

Additional info:
The application should use individual application names for the jgroups configuration files to not have this issue.

Comment 2 Martin Gencur 2014-12-05 15:21:55 UTC
PR: https://github.com/infinispan/jdg/pull/388


Note You need to log in before you can comment on or make changes to this bug.