Bug 1115618 - Update manpage to document service to enable
Summary: Update manpage to document service to enable
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: targetcli
Version: 7.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Andy Grover
QA Contact: Martin Hoyer
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-02 18:44 UTC by Andy Grover
Modified: 2017-08-01 20:54 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 20:54:35 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2031 normal SHIPPED_LIVE targetcli, python-configshell, python-rtslib bug fix and enhancement update 2017-08-01 18:34:25 UTC

Description Andy Grover 2014-07-02 18:44:23 UTC
The service to that must be enabled to restore the target configuration on restart is called target.service. It doesn't actually live in the targetcli pkg, it lives in the python-rtslib pkg. There's no good way for an admin to find this out, but they will in all likelihood want to enable it.

We should mention this in the "quickstart" section of the targetcli manpage, so users do not experience extreme frustration.

Comment 4 Martin Hoyer 2017-05-29 14:10:32 UTC
Tested with targetcli-2.1.fb46-1.el7. No regression found.
Manpage states that:

"Although  by default targetcli saves the running configuration upon exit, a distribution-specific service must be enabled to restore the saved configuration on reboot. See distribution documentation for specifics, but for example:

$ sudo systemctl enable target.service"

Comment 5 errata-xmlrpc 2017-08-01 20:54:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2031


Note You need to log in before you can comment on or make changes to this bug.