Bug 11157 - incorrect setting of dns search domains
Summary: incorrect setting of dns search domains
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: linuxconf   
(Show other bugs)
Version: 6.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-05-01 20:13 UTC by Eric Jorgensen
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-02 18:24:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Eric Jorgensen 2000-05-01 20:13:12 UTC
When entering additional dns search domains linuxconf fails to add the
current domain to the list of search domains, such that resolv.conf looks
like this:

domain: foo.com
search: bar.com
nameserver 1.2.3.4

With that conifguration in place, the resolver will (either incorrectly or
correctly) only search the bar.com domain. this may be a bug in the
resolver but one of the two needs to be fixed.

Comment 1 Nalin Dahyabhai 2000-05-02 18:24:59 UTC
This is not a bug.  There may in fact be situations where the local domain
should not be searched (for example, the "dsl.[myisp].net" domain).  If you
leave the search list blank, the default domain is used automatically.

Comment 2 Eric Jorgensen 2000-05-02 21:48:59 UTC
OK, maybe this is a cosmetic / cognitive thing. Probably just my QA experience
screaming "This is OK for me, but it's going to cause customer support issues".

If I'd thought more about it i could have come to that conclusion, but visually
with the fields marked "optional" it looks like they're intended to be
additional.

I could swear I've used an ip stack that interpreted resolv.conf differently
but i can't remember which (os/2 or something)


Note You need to log in before you can comment on or make changes to this bug.