Bug 1115744 - pulp errors upon install
Summary: pulp errors upon install
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Pulp
Version: 6.0.3
Hardware: x86_64
OS: Linux
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Justin Sherrill
QA Contact: Elyézer Rezende
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks: sat6-pulp-future
TreeView+ depends on / blocked
 
Reported: 2014-07-03 03:05 UTC by Brian J. Atkisson
Modified: 2020-01-11 17:34 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-12 13:57:59 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 9630 0 Normal Resolved pulp errors upon install 2020-01-11 17:30:03 UTC
Red Hat Bugzilla 1108555 0 unspecified CLOSED Installer errors in production.log - 1.) PGError: ERROR: relation "users" does not exist 2.) pulp user admin: already e... 2021-02-22 00:41:40 UTC

Internal Links: 1108555

Description Brian J. Atkisson 2014-07-03 03:05:03 UTC
Description of problem:

When running katello-installer, the install fished correctly, but these pulp error messages were written to /var/log/messages:

************
Jul  2 22:49:39 sat pulp: pulp.server.webservices.application:INFO: The Pulp server has been successfully initialized
Jul  2 22:49:39 sat pulp: pulp.server.webservices.application:INFO: *************************************************************
Jul  2 22:49:39 sat pulp: gofer.transport.qpid.broker:INFO: {sat.h.skunknetworks.com:5671} connected to AMQP
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR: Duplicate resource: admin
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR: Traceback (most recent call last):
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/pulp/server/webservices/middleware/exception.py", line 44, in __call__
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:     return self.app(environ, start_response)
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/pulp/server/webservices/middleware/postponed.py", line 42, in __call__
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:     return self.app(environ, start_response)
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/web/application.py", line 279, in wsgi
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:     result = self.handle_with_processors()
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 29, in _handle_with_processors
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:     return process(self.processors)
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 26, in process
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:     return p(lambda: process(processors))
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/web/application.py", line 566, in processor
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:     return handler()
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 26, in <lambda>
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:     return p(lambda: process(processors))
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 26, in process
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:     return p(lambda: process(processors))
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/web/application.py", line 581, in processor
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:     result = handler()
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 26, in <lambda>
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:     return p(lambda: process(processors))
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 28, in process
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:     return self.handle()
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/web/application.py", line 230, in handle
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:     return self._delegate(fn, self.fvars, args)
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/web/application.py", line 422, in _delegate
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:     return f()
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/web/application.py", line 430, in <lambda>
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:     f = lambda: self._delegate_sub_application(pat, what)
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/web/application.py", line 455, in _delegate_sub_application
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:     return app.handle_with_processors()
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 29, in _handle_with_processors
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:     return process(self.processors)
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 26, in process
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:     return p(lambda: process(processors))
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/web/application.py", line 566, in processor
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:     return handler()
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 26, in <lambda>
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:     return p(lambda: process(processors))
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 26, in process
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:     return p(lambda: process(processors))
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/web/application.py", line 581, in processor
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:     result = handler()
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 26, in <lambda>
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:     return p(lambda: process(processors))
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/pulp/server/webservices/application.py", line 28, in process
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:     return self.handle()
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/web/application.py", line 230, in handle
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:     return self._delegate(fn, self.fvars, args)
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/web/application.py", line 420, in _delegate
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:     return handle_class(cls)
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/web/application.py", line 396, in handle_class
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:     return tocall(*args)
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/pulp/server/webservices/controllers/decorators.py", line 227, in _auth_decorator
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:     value = method(self, *args, **kwargs)
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/pulp/server/webservices/controllers/users.py", line 76, in POST
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:     user = manager.create_user(*args, **kwargs)
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:   File "/usr/lib/python2.6/site-packages/pulp/server/managers/auth/user/cud.py", line 63, in create_user
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR:     raise DuplicateResource(login)
Jul  2 22:50:39 sat pulp: pulp.server.webservices.middleware.exception:ERROR: DuplicateResource: Duplicate resource: admi

Version-Release number of selected component (if applicable):

python-pulp-common-2.4.0-0.23.beta.el6sat.noarch
python-pulp-puppet-common-2.4.0-0.23.beta.el6sat.noarch
mod_wsgi-3.4-1.pulp.el6sat.x86_64
pulp-puppet-tools-2.4.0-0.23.beta.el6sat.noarch
python-pulp-rpm-common-2.4.0-0.23.beta.el6sat.noarch
python-pulp-bindings-2.4.0-0.23.beta.el6sat.noarch
pulp-nodes-common-2.4.0-0.23.beta.el6sat.noarch
pulp-puppet-plugins-2.4.0-0.23.beta.el6sat.noarch
pulp-rpm-plugins-2.4.0-0.23.beta.el6sat.noarch
python-isodate-0.5.0-1.pulp.el6sat.noarch
m2crypto-0.21.1.pulp-10.el6sat.x86_64
pulp-server-2.4.0-0.23.beta.el6sat.noarch
pulp-katello-0.3-3.el6sat.noarch
pulp-nodes-parent-2.4.0-0.23.beta.el6sat.noarch
createrepo-0.9.9-21.2.pulp.el6sat.noarch
python-kombu-3.0.15-10.pulp.el6sat.noarch
pulp-selinux-2.4.0-0.23.beta.el6sat.noarch
katello-1.5.0-26.el6sat.noarch

How reproducible:
unknown

Steps to Reproduce:
1. run katello-install
2. watch /var/log/messages

Comment 1 RHEL Program Management 2014-07-03 03:24:53 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Clifford Perry 2014-07-11 10:00:14 UTC
Duplicate of bug 1108555 ?

Comment 4 Justin Sherrill 2015-03-03 22:36:22 UTC
Created redmine issue http://projects.theforeman.org/issues/9630 from this bug

Comment 7 Justin Sherrill 2015-03-04 16:20:50 UTC
This was resolved in pulp 2.6

Comment 8 Elyézer Rezende 2015-04-06 14:00:27 UTC
Verified on Satellite-6.1.0-RHEL-7-20150331.1

Steps to verify:

1. Installed Setellite 6.1
2. Checked /var/log/messages for errors:

# grep -E "pulp:.*ERROR" /var/log/messages
#

Comment 9 Bryan Kearney 2015-08-11 13:32:26 UTC
This bug is slated to be released with Satellite 6.1.

Comment 10 Bryan Kearney 2015-08-12 13:57:59 UTC
This bug was fixed in version 6.1.1 of Satellite which was released on 12 August, 2015.


Note You need to log in before you can comment on or make changes to this bug.