Bug 111590 - (intelstolenmemory) correct amount of video memory not detected w/ Intel 865G chipset
correct amount of video memory not detected w/ Intel 865G chipset
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: XFree86 (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-05 14:46 EST by Erich Morisse
Modified: 2007-11-30 17:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-05 16:44:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Erich Morisse 2003-12-05 14:46:46 EST
Description of problem:
Only 832kb of video memory is detected regardless of amount in card
and/or BIOS settings.

Neither the base driver, nor the driver from
http://www.intel.com/support/graphics/linux/ solved the problem.

kernel-2.4.21-4.EL && XFree86-4.3.0-35.EL 

How reproducible:
Always

Steps to Reproduce:
1.  Install on Dell Optiplex GX270
2.  startx
3.
    

Additional info:

The Dell Optiplex GX270 has embeded Intel Extreme Graphics 2 video
which uses the 865G chipset.
Comment 1 Mike A. Harris 2003-12-05 16:44:55 EST
This is not a video driver bug or XFree86 bug.  This is a bug in
the video BIOS itself.  Intel integrated video hardware uses a
UMA (Unified Memory Architecture) in which the main system memory
is shared with the video device.  This memory is referred to as
"stolen" memory, and the amount of memory that gets stolen is
determined by the video BIOS at system POST time.  A BIOS which
was implemented properly to Intel's specifications, allows this
value to be configured by the user in the CMOS setup screen or
equivalent feature, however some manufacturers violate Intel's
specification and do not allow this value to be changed in their
CMOS setup.  The Intel developer website has information on this
BIOS misimplementation problem, and this has been a cause of
problem for Linux users for quite some time now, in particular
on Dell laptops and other Dell hardware.

The XFree86 video driver is limited to using the amount of memory
that the system has configured the video device to use, and no more
than that.  Your BIOS has configured the video adaptor to have
only 832Kb of memory available, and so that is all XFree86 ever
sees available.

This problem does not happen in Microsoft Windows OS, because Intel's
own video drivers know how to program the chipset directly to
reprogram the amount of video memory inside the video driver, just
like the BIOS does.  Since Intel has the complete technical
specifications for how to do this, they have no problem implementing
this BIOS bug workaround in their video drivers for Windows.

Intel's video hardware documentation is not available to the open
source community, nor is any information on how to tweak the XFree86
i8xx video driver to bypass this limitation.  As such, this BIOS
firmware bug affects all users of open source operating systems,
and we can not do anything about it other than wait for Intel to
supply patches to the i8xx video driver to work around the issue
by programming the chipset directly, or for Intel to release the
specifications for their video hardware to the OSS community.

If Intel does release the specificiations, then whoever investigates
the problem will require physical access to the hardware in addition
to the hardware specification in order to develop a workaround
solution to this problem.

This very same problem affected Dell laptops with i830 video in
them about a year and a half ago, and it took about 8-12 months
for a workaround to be implemented in XFree86, and only after
the required information has been provided to the community.

Closing bug as NOTABUG, as this is a BIOS firmware bug in Dell
systems, and not a video driver bug.  Once a workaround for this
problem has been made available by Intel, we can review it for
potential inclusion in future OS releases, and possibly future
erratum for existing releases depending on how big the changes
are.

Comment 2 Bastien Nocera 2004-02-12 10:38:44 EST
A work-around is available at:
http://www.chzsoft.com.ar/855patch.html

Note You need to log in before you can comment on or make changes to this bug.