Bug 111592 - vim-6.2.154-5 needs missing perl-5.8.2-2 dependency
vim-6.2.154-5 needs missing perl-5.8.2-2 dependency
Product: Red Hat Raw Hide
Classification: Retired
Component: vim (Show other bugs)
All Linux
medium Severity high
: ---
: ---
Assigned To: Karsten Hopp
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2003-12-05 14:59 EST by Felipe Alfaro Solana
Modified: 2007-04-18 12:59 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-01-13 07:50:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Felipe Alfaro Solana 2003-12-05 14:59:19 EST
Description of problem:
The /usr/bin/vim binary from package vim-6.2.154-5 requires the
libperl.so dynamic library that comes with perl-5.8.2-2. However, the
vim-6.2.154-5 RPM package does not require at least perl version 5.8.2.

Running "ldd /usr/bin/vim" when perl 5.8.1 is installed complains that
/usr/lib/libperl.so is missing. Upgrading from perl-5.8.1 to
perl-5.8.2-2 solves the problem.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Make sure perl-5.8.1 is installed
2. Install/upgrade to vim-6.2.154-5
3. ldd /usr/bin/vim

Ldd will complain about missing /usr/lib/libperl.so dynamic library.
Upgrading to perl-5.8.2 solves the problem.
Actual results:
vim-6.2.154-5 does not depend on perl-5.8.2-2

Expected results:
vim-6.2.154-5 should depend on perl-5.8.2-2

Additional info:
Comment 1 Karsten Hopp 2004-01-13 07:50:43 EST
will be fixed in one of the next releases, patch already commited to 
Comment 2 Robert Scheck 2004-01-24 11:21:50 EST
Hm, in my eyes that change/fix is still foo, bar or gaga ;-) 

vim-enhanced ONLY requires perl!

The following was generated with ldd after an rebuild from the latest 
vim at Red Hat 9 - perl 5.8.0 used:

--- snipp ---
libperl.so => /usr/lib/perl5/5.8.0/i386-linux-thread-multi/CORE/libperl.so (0x40068000)
--- snapp ---

I think, the problem above was, that vim wasn't rebuilded (or not 

Please change the dependence to "perl" instead of "perl >= 5.8.x" :)

Thank you.
Comment 3 Karsten Hopp 2004-01-26 06:20:04 EST
No, vim-enhanced really needs to require the right perl version, but 
I've changed the requires line to check which version is installed 
at build-time. 

Note You need to log in before you can comment on or make changes to this bug.