Bug 111608 - Interactive behaviour afected when given root password
Interactive behaviour afected when given root password
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: usermode (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Bacovsky
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-06 02:19 EST by Jules Colding
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: FC5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-21 22:08:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jules Colding 2003-12-06 02:19:49 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
Launch up2date as non-root. While it is querying for the root password
try to:

1) Launch the fedora (aka the foot menu) menu

2) or try to type something in a gnome-termnal

3) or try to type something in an emacs buffer

It is simply not possible to launch the main menu or type anything
except in the password query window itself. It should be noted that
this are only true when being in the same workspace as the query window.  

Version-Release number of selected component (if applicable):
up2date-4.1.16-1

How reproducible:
Always

Steps to Reproduce:
1. Launch up2date as non-rrot
2. Try to press the fedora menu or
3. Try to input something in another program
    

Additional info:
Comment 1 Adrian Likins 2003-12-08 17:33:58 EST
the root password dialog is part of the "usermode" program,
and not up2date itself, reassigning to the "usermode"
component.
Comment 2 Jindrich Novy 2005-05-19 10:10:56 EDT
I can't reproduce this with usermode-1.80-1 any more.
Comment 3 Jindrich Novy 2005-05-19 10:40:04 EDT
I ran debug version of usermode where this feature is disabled. This really
happens even with rawhide usermode.
Comment 4 Jindrich Novy 2005-05-19 10:48:33 EDT
On the other hand, this behavior is intentional in order to not to give user a
chance to type password in a visible form to some other window if he
accidentially change focus. I'll set the password window always on top in order
to not to let the user be confused if he switches to another window what covers
the password dialog and anything he types goes to password query window actually.
Comment 5 Bill Nottingham 2006-09-21 22:08:04 EDT
Closing bugs in MODIFIED state from prior Fedora releases. If this bug persists
in a current Fedora release (such as Fedora Core 5 or later), please reopen and
set the version appropriately.

Note You need to log in before you can comment on or make changes to this bug.