Bug 111612 - Pointless error message about "emh-setup"
Summary: Pointless error message about "emh-setup"
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: wl
Version: 1
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Jens Petersen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-12-06 14:33 UTC by Reuben Thomas
Modified: 2007-11-30 22:10 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2005-12-20 07:45:09 UTC


Attachments (Terms of Use)

Description Reuben Thomas 2003-12-06 14:33:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; Linux i686; U) Opera 7.23  [en]

Description of problem:
When starting up semi (in particular, running the file 
/usr/share/emacs/site-lisp/semi/mime-setup.el) I get the pointless 
error message

emh-setup is not found.

emh-setup.el is not supplied (it used to be in the semi package) but 
it's not needed, as it's for EMH, not Wanderlust.

I'm not sure what the underlying problem is. mime-setup.el clearly 
shouldn't be trying to load these two files (mime-setup and 
gnus-mime-setup) unless the user actually wants to use Gnus or EMH 
respectively with SEMI. Since these files are part of the wl RPM, 
presumably they're not there to be used either with Gnus or EMH.

Version-Release number of selected component (if applicable):
2.10.1-1.1

How reproducible:
Always

Steps to Reproduce:
I use the following to load wl during my Emacs startup. It's pretty 
much the code recommended in the wl docs.

(autoload 'wl-user-agent-compose "wl-draft" nil t)
(if (boundp 'mail-user-agent)
    (setq mail-user-agent 'wl-user-agent))
(if (fboundp 'define-mail-user-agent)
    (define-mail-user-agent
      'wl-user-agent
      'wl-user-agent-compose
      'wl-draft-send
      'wl-draft-kill
      'mail-send-hook))
(setq wl-message-buffer-cache-size 0)
(autoload 'x-face-decode-message-header "x-face-e21")
(setq wl-highlight-x-face-function 'x-face-decode-message-header)
    

Actual Results:  I get the error above. It seems to be harmless.

Expected Results:  I shouldn't get an error, as there's nothing 
wrong.

Additional info:

Comment 1 Jens Petersen 2004-09-29 18:35:42 UTC
I have a feeling this is fixed in FC2 - could you try with that or
newer please.  If not where does the error appear?

Comment 2 Reuben Thomas 2004-09-30 22:48:12 UTC
Sorry, I no longer use Fedora, so I can't check this.

Comment 3 Jens Petersen 2004-10-06 13:22:51 UTC
Ok, thanks - actually trying wl, I see that those two warnings
are still appearing in the *Messages*.

Comment 4 Jens Petersen 2004-10-06 13:31:33 UTC
Fixing in wl-2.10.1-4.


Note You need to log in before you can comment on or make changes to this bug.