Bug 111614 - fgrep -i changes caps to lowercase
fgrep -i changes caps to lowercase
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: grep (Show other bugs)
1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-06 10:50 EST by Rik Faith
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-05 07:21:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rik Faith 2003-12-06 10:50:16 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031007 Firebird/0.7

Description of problem:
It may be most helpful to show what all the greps do on my system, so
this is formatted as grep-version followed by the output of:
echo Foo | fgrep -i foo:

grep-2.5.1-17.2 foo    wrong
grep-2.5.1-17   Foo    ok (version from perf7.perf rawhide repository)
grep-2.5.1-19   foo    wrong (perf7.perf)
grep-2.5.1-20   foo    wrong (perf7.perf)



Version-Release number of selected component (if applicable):
grep-2.5.1-17.2

How reproducible:
Always

Steps to Reproduce:
1.See above
2.
3.
    

Actual Results:  See above

Expected Results:  See above

Additional info:
Comment 1 Tim Waugh 2003-12-06 11:01:49 EST
Judging from the version numbers this is caused by the UTF-8 speed-up
patch. :-(
Comment 2 Tim Waugh 2003-12-06 18:05:13 EST
Please try 2.5.1-21.
Comment 3 Tim Waugh 2004-01-05 07:21:09 EST
Fedora Core 1 update is 2.5.1-17.4.
Comment 4 Jay Turner 2004-09-01 22:13:25 EDT
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-079.html

Note You need to log in before you can comment on or make changes to this bug.