Bug 111624 - Cannot add Sun or Bea JRE to Preferences
Summary: Cannot add Sun or Bea JRE to Preferences
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Developer Suite
Classification: Retired
Component: eclipse   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: eclipse-bugs
QA Contact: eclipse-bugs
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-12-06 19:27 UTC by Brad Smith
Modified: 2007-04-18 16:59 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-18 15:29:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Brad Smith 2003-12-06 19:27:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030922

Description of problem:
I cannot add the Sun (1.4.2) or Bea (jrocket from RHEL iso) JREs to
Preferences in Eclipse. When I add the required information (jre name,
jre home directory) the Ok button remains grayed out. I easily added
the IBM JRE (from the RHEL iso).

Version-Release number of selected component (if applicable):
eclipse-2.1.0-22

How reproducible:
Always

Steps to Reproduce:
1.Open Eclipse
2.Open Window | Preferences
3.Select Java and then Installed JREs
4.Click on Add
5.Enter correct info
    

Actual Results:  Ok button remains grayed out.

Expected Results:  Ok Button should become clickable.

Additional info:

The Sun SDK was installed from the Sun 1.4.2 SDK rpm. The BEA SDK was
installed with te RHEL rpm.

Comment 1 Jeremy Handcock 2003-12-08 20:18:23 UTC
I'm having trouble reproducing this.

For the BEA JRockit SDK distributed with RHEL3, I have the "JRE home
directory" field in the "Edit JRE" dialog set to
/opt/bea/jrockit81sp1rp1_141_05.

For the Sun 1.4.2 SDK, I have the "JRE home directory" field in the
"Edit JRE" dialog set to /usr/java/j2sdk1.4.2.

The OK button becomes clickable for me in both cases.  Are these the
JRE home directories that you entered?

As a side-note, please be aware that the BEA JRockit SDK requires you
to set the environment variable LD_ASSUME_KERNEL=2.4.1 (as mentioned
in the release notes).

Comment 2 Jeremy Handcock 2003-12-08 20:25:36 UTC
Reopening while waiting for additional information.

Comment 3 Brad Smith 2003-12-12 03:50:01 UTC
Yes these are the directories I entered. Also note that if I start
Eclipse with the -vm option and specify the Sun JVM then I not longer
have the problem. I am not sure what is happening.

Brad


Comment 4 Jeremy Handcock 2003-12-18 15:29:16 UTC
We've tried this on stock RHEL3 machines with the eclipse-2.1.0-22
RPM, and we cannot reproduce this behavior.

I'm not sure what the problem here could be - I've never seen this
behavior before.

I have also tried to reproduce this problem on the eclipse package
that will ship with RHEL3 Update 1, and cannot reproduce.  May I
suggest that you upgrade to the new package when it becomes available
on RHN.

Comment 5 John Healy 2004-03-08 21:21:37 UTC
Moving from RHEL/3/Eclipse to Red Hat Developer Suite product.


Note You need to log in before you can comment on or make changes to this bug.