Bug 1116561 - [vdsm] refresh images list for ISO domain fails with an AttributeError in getFileStats
Summary: [vdsm] refresh images list for ISO domain fails with an AttributeError in get...
Keywords:
Status: CLOSED DUPLICATE of bug 1114499
Alias: None
Product: oVirt
Classification: Retired
Component: vdsm
Version: 3.5
Hardware: x86_64
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.5.0
Assignee: Yeela Kaplan
QA Contact: Gil Klein
URL:
Whiteboard: infra
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-06 10:48 UTC by Elad
Modified: 2016-02-10 19:32 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-07 10:55:29 UTC
oVirt Team: Infra


Attachments (Terms of Use)
logs from engine and host (1.99 MB, application/x-gzip)
2014-07-06 10:48 UTC, Elad
no flags Details

Description Elad 2014-07-06 10:48:34 UTC
Created attachment 914945 [details]
logs from engine and host

Description of problem:
VDSM is unable to refresh the images list for an ISO domain because of an AttributeError for getFileStats

Version-Release number of selected component (if applicable):
vdsm-4.16.0-3.git601f786.el6.x86_64
libvirt-0.10.2-29.el6_5.9.x86_64
qemu-kvm-0.12.1.2-2.415.el6_5.10.x86_64
ovirt-engine-3.5.0-0.0.master.20140629172257.git0b16ed7.el6.noarch


How reproducible:
Always

Steps to Reproduce:
1. Attach NFS ISO domain to the DC


Actual results:

VDSM cannot refresh the ISO domain images list:

Thread-50::ERROR::2014-07-06 12:15:41,782::task::866::Storage.TaskManager.Task::(_setError) Task=`4a49c453-80bb-462a-8550-c2907dba6cc1`::Unexpected error
Traceback (most recent call last):
  File "/usr/share/vdsm/storage/task.py", line 873, in _run
    return fn(*args, **kargs)
  File "/usr/share/vdsm/logUtils.py", line 45, in wrapper
    res = f(*args, **kwargs)
  File "/usr/share/vdsm/storage/hsm.py", line 2299, in getFileStats
    caseSensitive=caseSensitive)
  File "/usr/share/vdsm/storage/fileSD.py", line 285, in getFileList
    self.oop.fileUtils.validateQemuReadable(entry)
AttributeError: '_IOProcessFileUtils' object has no attribute 'validateQemuReadable'


Expected results:
Refresh images list of ISO domain should work

Additional info: logs from engine and host

Comment 1 Yeela Kaplan 2014-07-07 10:55:29 UTC

*** This bug has been marked as a duplicate of bug 1114499 ***


Note You need to log in before you can comment on or make changes to this bug.