Bug 111661 - CD-ROM locks when trying to mount hfs+ CD
CD-ROM locks when trying to mount hfs+ CD
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
1
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Arjan van de Ven
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-08 05:00 EST by Arthur Pirogovski
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-29 15:48:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arthur Pirogovski 2003-12-08 05:00:13 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030

Description of problem:
When I tried to mount hfs+ CD in my CD-ROM, I've got kernel bug
message in dmesg.
After this, I was unable to eject my CD.

Version-Release number of selected component (if applicable):
kernel-2.4.22-1.2115.nptl

How reproducible:
Always

Steps to Reproduce:
1. Insert HFS Extended CD into CD-ROM
2. #mount -t hfs /dev/cdrom /mnt/cdrom // I know it's weird - hfs is
not hfs+ and is not supported on CD, but anyway it must not crash.
3. look in dmesg
    

Actual Results:  a kernel bug message appeared in logs. CD-ROM is
locked so it cannot be ejected manually nor via eject command.
eject says:
eject: unable to eject, last error: Invalid argument

Expected Results:  an error message with possibility to unmount CD.

Additional info:

kernel BUG at buffer.c:2663!
invalid operand: 0000
hfs udf appletalk i810_audio ac97_codec soundcore parport_pc lp
parport autofs e100 floppy sg sr_mod microcode ide-scsi scsi_mod
ide-cd cdrom nls_utf8 nls_cp8
CPU:    0
EIP:    0060:[<c0149b19>]    Not tainted
EFLAGS: 00010206

EIP is at grow_buffers [kernel] 0x39 (2.4.22-1.2115.nptl)
eax: 000007ff   ebx: 00000b00   ecx: 00000800   edx: c13b4c40
esi: 00000b00   edi: 00000200   ebp: 00000b00   esp: c180bd94
ds: 0068   es: 0068   ss: 0068
Process mount (pid: 4102, stackpage=c180b000)
Stack: d09a9f21 cc4d6000 d09ad31e 00000282 00000000 00000b00 00000200
00000002
       c01474d6 00000b00 00000002 00000200 c180a000 c40970ec 00000001
c4097000
       00000002 c0147790 00000b00 00000002 00000200 00000005 d09aab2a
00000b00
Call Trace:   [<d09a9f21>] parse_options [hfs] 0xb1 (0xc180bd94)
[<d09ad31e>] .rodata.str1.1 [hfs] 0x12a (0xc180bd9c)
[<c01474d6>] getblk [kernel] 0x46 (0xc180bdb4)
[<c0147790>] bread [kernel] 0x20 (0xc180bdd8)
[<d09aab2a>] hfs_buffer_get [hfs] 0x3a (0xc180bdec)
[<d09a90f9>] hfs_mdb_get [hfs] 0x99 (0xc180be0c)
[<d08fd0d1>] scsi_ioctl_Rf7a5b7ef [scsi_mod] 0x101 (0xc180be34)
[<d09aa7d5>] hfs_read_super [hfs] 0x95 (0xc180be50)
[<d091c17b>] sr_media_change [sr_mod] 0x5b (0xc180be64)
[<d08e5ee0>] media_changed [cdrom] 0x60 (0xc180be7c)
[<c014a6fa>] alloc_super [kernel] 0x3a (0xc180be90)
[<c014c518>] check_disk_change [kernel] 0x48 (0xc180bea0)
[<c014b183>] get_sb_bdev [kernel] 0x1a3 (0xc180beb4)
[<d09b0430>] hfs_fs [hfs] 0x0 (0xc180bef8)
[<c014b4f1>] do_kern_mount [kernel] 0x121 (0xc180bf00)
[<d09b0430>] hfs_fs [hfs] 0x0 (0xc180bf04)
[<c015ec53>] do_add_mount [kernel] 0x93 (0xc180bf24)
[<c015ef80>] do_mount [kernel] 0x160 (0xc180bf44)
[<c015edc9>] copy_mount_options [kernel] 0x79 (0xc180bf74)
[<c015f3a1>] sys_mount [kernel] 0xb1 (0xc180bf94)
[<c0109b9f>] system_call [kernel] 0x33 (0xc180bfc0)


Code: 0f 0b 67 0a 37 a9 28 c0 8d 87 00 fe ff ff 3d 00 0e 00 00 76
Comment 1 Penelope Fudd 2004-02-04 18:55:23 EST
I have the same problem, except that:

 1) I don't have any disk in the drive
 2) It hasn't paniced yet

However, I can type 'eject' all I want, it won't do any good; and the
eject button on the cdrom drive doesn't work.  The kernel messages are
mostly the same:

udf: registering filesystem
sr0: CDROM (ioctl) reports ILLEGAL REQUEST.
cdrom: open failed.
sr0: CDROM (ioctl) reports ILLEGAL REQUEST.
cdrom: open failed.
(it was repeated 9 times; I guess I tried that many times)

This is on a Dell Inspiron 7500, with a fresh, vanilla Fedora core 1
workstation with no customization.  I mean I haven't installed *any*
software at all.  And until I reboot, I suspect I *can't* install any
software (from cdrom).  I'm using the same kernel as the reporter.

lsmod says these modules are loaded:
xircom_cb udf maestro soundcore parport_pc lp parport autofs ds
yenta_socket pcmcia_core ipt_REJECT ipt_state ip_conntrack 
iptable_filter ip_tables floppy sg sr_mod microcode ide-scsi scsi_mod
ide-cd cdrom keybdev hid usb-uhci usbcore mousedev input ext3 jbd

The xircom_cb was added after the problem started; it's my network
pcmcia card.

I'm off to try the fedora update system.
Comment 2 David Lawrence 2004-09-29 15:48:59 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.