Bug 111668 - Cannot install xemacs with redhat-config-packages
Summary: Cannot install xemacs with redhat-config-packages
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: redhat-config-packages   
(Show other bugs)
Version: 3
Hardware: athlon Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-12-08 15:14 UTC by Carlos Rodrigues
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 20:15:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Carlos Rodrigues 2003-12-08 15:14:54 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031117

Description of problem:
I'm trying to install xemacs with redhat-config-packages and all I get
is this error (when I click in the checkbox):

Traceback (most recent call last):
  File "/usr/share/redhat-config-packages/GroupDetails.py", line 171,
in renderer_toggled
    self.component.selectPackage(package.nevra())
  File "/usr/share/redhat-config-packages/GroupSet.py", line 794, in
selectPackage
    pkg = self.packages[pkgnevra]
KeyError: xemacs-0:21.4.14-3.i386
 
Additionally and also can't uninstall emacs, when I click the checkbox
I get the following error:

Traceback (most recent call last):
  File "/usr/share/redhat-config-packages/GroupDetails.py", line 169,
in renderer_toggled
    self.component.unselectPackage(package.nevra())
  File "/usr/share/redhat-config-packages/GroupSet.py", line 841, in
unselectPackage
    pkg = self.packages[pkgnevra]
KeyError: emacs-0:21.3-7.i386
 


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. redhat-config-packages
2. go to the "editors" group
3. try to install xemacs or uninstall emacs
    

Actual Results:  Errors appear on the console.

Expected Results:  The checkbox should change it's state, nothing else.

Additional info:

Comment 1 Keith Cappello 2004-05-13 15:22:53 UTC
We have tried doing this same thing on Enterprise WS class and also 
having the same problem.  We can get it to install via the command 
line using the RPM command.

Comment 2 Carlos Rodrigues 2004-07-09 18:41:26 UTC
This problem still persists on FC2...

Comment 3 Carlos Rodrigues 2004-11-29 02:25:01 UTC
Still happens in FC3...

Comment 4 Jeremy Katz 2005-09-21 20:15:56 UTC
This report is filed against a product which is no longer supported.  It is very
likely that the problem is resolved in the current version of Fedora Core or
scheduled to be resolved with the new system-config-packages scheduled to land
in Fedora Core 5.


Note You need to log in before you can comment on or make changes to this bug.