Bug 1116744 - Indicate that sub components are required when creating a bug
Indicate that sub components are required when creating a bug
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Creating/Changing Bugs (Show other bugs)
4.4
Unspecified Unspecified
medium Severity medium (vote)
: ---
: ---
Assigned To: Matt Tyson
Simon Green
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-07-07 04:32 EDT by Moritoshi Oshiro
Modified: 2014-10-12 18:52 EDT (History)
4 users (show)

See Also:
Fixed In Version: 4.4.4022
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-27 20:42:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Moritoshi Oshiro 2014-07-07 04:32:14 EDT
Created attachment 915998 [details]
screenshot

Description of problem:
When creating a bz ticket for kernel component, a user tries to complete a new one without specifying Sub Component and it results an error. 

The sub component of kernel is not stated as "* = Required Field" in the new creation page, but it looks like a required field. 

Please put the * next to sub component showing a user that it is a required field or fix the submission such that sub component is not specified but it can be submitted.  


Version-Release number of selected component (if applicable):


How reproducible:
Always 

Steps to Reproduce:
1. Select kernel as a component
2. Do not select sub component of kernel
3. Fill in other fields
4. Submit the new report

Actual results:
Error occurs and submitting a new report fails.

Expected results:
Error does not occur and submitting a new report succeeds.
OR
Specify "* Sub Component" indicating that it is a required field. 




Additional info:
Please see uploaded file which is a screen shot of partial page.
Comment 2 Matt Tyson 2014-07-13 19:22:11 EDT
Sub components will now show an asterisk where applicable.
Comment 3 Matt Tyson 2014-07-27 20:42:59 EDT
This change is now live. If there are any issues, do not reopen this bug.
Instead, you should create a new bug and reference this bug.

Note You need to log in before you can comment on or make changes to this bug.