Bug 1116764 - Basic operations failing in REST
Summary: Basic operations failing in REST
Keywords:
Status: CLOSED DUPLICATE of bug 1113485
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-api
Version: 3.5
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
: 3.5.0
Assignee: Juan Hernández
QA Contact: Pavel Stehlik
URL:
Whiteboard: infra
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-07 09:13 UTC by GenadiC
Modified: 2016-02-10 19:30 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-14 11:36:20 UTC
oVirt Team: Infra


Attachments (Terms of Use)

Description GenadiC 2014-07-07 09:13:38 UTC
Description of problem:
Trying to perform basic operation with API, like adding a new DC or add a Network to DC or Host fails with Error 500

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Try to create a new DC with API
2. Try to create it with SDK
3.

Actual results:
Error 500 on basic API action
http://pastebin.test.redhat.com/219780 when creating it with SDK

Expected results:
Action should succeed

Additional info:


2014-07-06 15:14:50,173 - MainThread - datacenters - ERROR - https://10.35.160.222/api/datacenters
2014-07-06 15:14:50,174 - MainThread - datacenters - ERROR - <data_center>
    <name>test_dc_35</name>
    <storage_type>iscsi</storage_type>
    <version major="3" minor="5"/>
</data_center>

2014-07-06 15:14:50,429 - MainThread - datacenters - ERROR - {'status': 500, 'body': u'<html><head><title>JBoss Web/7.0.13.Final - Error report</title><style><!--H1 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:22px;} H2 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:16px;} H3 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:14px;} BODY {font-family:Tahoma,Arial,sans-serif;color:black;background-color:white;} B {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;} P {font-family:Tahoma,Arial,sans-serif;background:white;color:black;font-size:12px;}A {color : black;}A.name {color : black;}HR {color : #525D76;}--></style> </head><body><h1>HTTP Status 500 - Bad arguments passed to public abstract javax.ws.rs.core.Response org.ovirt.engine.api.resource.DataCentersResource.add(org.ovirt.engine.api.model.DataCenter)  ( org.ovirt.engine.api.model.DataCenter org.ovirt.engine.api.model.DataCenter@4677b6f7 )</h1><HR size="1" noshade="noshade"><p><b>type</b> Status report</p><p><b>message</b> <u>Bad arguments passed to public abstract javax.ws.rs.core.Response org.ovirt.engine.api.resource.DataCentersResource.add(org.ovirt.engine.api.model.DataCenter)  ( org.ovirt.engine.api.model.DataCenter org.ovirt.engine.api.model.DataCenter@4677b6f7 )</u></p><p><b>description</b> <u>The server encountered an internal error (Bad arguments passed to public abstract javax.ws.rs.core.Response org.ovirt.engine.api.resource.DataCentersResource.add(org.ovirt.engine.api.model.DataCenter)  ( org.ovirt.engine.api.model.DataCenter org.ovirt.engine.api.model.DataCenter@4677b6f7 )) that prevented it from fulfilling this request.</u></p><HR size="1" noshade="noshade"><h3>JBoss Web/7.0.13.Final</h3></body></html>', 'reason': 'Internal Server Error'}
2014-07-06 15:14:50,665 - MainThread - datacenters - ERROR - Response code is not valid, expected is: [200, 201, 202], actual is: 500

Comment 1 Juan Hernández 2014-07-14 11:36:20 UTC

*** This bug has been marked as a duplicate of bug 1113485 ***


Note You need to log in before you can comment on or make changes to this bug.