Bug 111691 - kernel 2.4.21-4.0.1.EL has no apm support (tested on dell d600 laptop)
kernel 2.4.21-4.0.1.EL has no apm support (tested on dell d600 laptop)
Status: CLOSED DUPLICATE of bug 111689
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2003-12-08 15:37 EST by Helmut G. Katzgraber
Modified: 2007-11-30 17:06 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:00:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Helmut G. Katzgraber 2003-12-08 15:37:36 EST
Description of problem:

when running apm -s with the 2.4.21-4.0.1.EL kernel, apm returns

[root@localhost]# /usr/bin/apm -s
No APM support in kernel

more details:

[root@localhost]# uname -a
Linux localhost.localdomain 2.4.21-4.0.1.EL #1 Thu Oct 23 01:36:33 EDT 2003
i686 i686 i386 GNU/Linux

there exists no file called "/proc/apm".

Version-Release number of selected component (if applicable):

kernel: kernel-2.4.21-4.0.1.EL
apm: apmd-3.0.2-18

How reproducible:

Tested on one system. Not sure if reproducible but seems to be simple: apm is not 
compiled into the upgraded kernel.

Steps to Reproduce:
1. Install RHEL WS 3.0 on a laptop. run up2date-nox and upgrade the kernel to
2. try to put the laptop to sleep with apm: /usr/bin/apm -s (nothing happens, 
program mentions that there is no support for APM in the kernel.
Actual results:

program exits with above mentioned error message: "No APM support in kernel"

Expected results:

laptop goes into suspend mode.

Additional info: output from dmesg after a boot attached later.
Comment 1 Bill Nottingham 2003-12-08 15:54:56 EST

*** This bug has been marked as a duplicate of 111689 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:00:19 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.