Bug 1117016 - RFE: Unable to CSV import or export 'Access Policy' for Beaker hosts
Summary: RFE: Unable to CSV import or export 'Access Policy' for Beaker hosts
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Beaker
Classification: Community
Component: inventory
Version: 0.16
Hardware: All
OS: All
unspecified
unspecified vote
Target Milestone: ---
Assignee: beaker-dev-list
QA Contact: tools-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-07 19:54 UTC by Keith Fryklund
Modified: 2018-02-06 00:41 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-09 05:04:11 UTC


Attachments (Terms of Use)

Description Keith Fryklund 2014-07-07 19:54:52 UTC
Description of problem:
I can't export/import 'Access Policy' rules for new Beaker hosts which creates a significant amount of additional work when adding systems in bulk to Beaker.

Version-Release number of selected component (if applicable):
Beaker Version 0.16.2

Steps to Reproduce:
1. Go to the beaker home page
2. Go to Admin > Export

Actual results:
No 'System Access Policy' option available

Comment 2 Dan Callaghan 2014-07-07 22:29:09 UTC
Can you use the bkr client in a bash loop? For example:

    while read fqdn ; do
        bkr policy-grant --system=$fqdn --permission=reserve --group=colonel
        bkr policy-grant --system=$fqdn --permission=edit_system --group=colonel
    done <new-systems.txt

We are trying to move towards using the bkr client rather than CSV files for data automation, since it is generally more flexible, simpler to use, and simpler for us to implement. Especially for something like system access policies which don't really map well to a tabular format like CSV.

Comment 3 Keith Fryklund 2014-07-08 14:29:29 UTC
(In reply to Dan Callaghan from comment #2)
> Can you use the bkr client in a bash loop? For example:
> 
>     while read fqdn ; do
>         bkr policy-grant --system=$fqdn --permission=reserve --group=colonel
>         bkr policy-grant --system=$fqdn --permission=edit_system
> --group=colonel
>     done <new-systems.txt
> 
> We are trying to move towards using the bkr client rather than CSV files for
> data automation, since it is generally more flexible, simpler to use, and
> simpler for us to implement. Especially for something like system access
> policies which don't really map well to a tabular format like CSV.

Awesome, I was unaware bkr client had the capability to do this.  I much prefer bkr client over CSV as well. Thank you for your help, feel free to close this ticket.

Comment 4 Dan Callaghan 2014-07-09 05:04:11 UTC
WONTFIX since bkr client is preferred over CSV.


Note You need to log in before you can comment on or make changes to this bug.