Bug 1117132 - Error reporting has issue with python 2.7 i18n
Summary: Error reporting has issue with python 2.7 i18n
Keywords:
Status: CLOSED DUPLICATE of bug 1112704
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-07-08 06:30 UTC by Clément DAVID
Modified: 2014-07-08 06:42 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-08 06:42:50 UTC
Type: Bug


Attachments (Terms of Use)

Description Clément DAVID 2014-07-08 06:30:02 UTC
Description of problem:
'dnf update' reports an error with backtrace whereas 'yum update' reports the right problem.

Version-Release number of selected component (if applicable):

$ dnf --version
0.5.2
  Installés : dnf-0:0.5.2-1.fc20.noarch à 2014-06-01 14:09
  Compilé   : Fedora Project à 2014-05-28 08:51

  Installés : rpm-0:4.11.2-2.fc20.x86_64 à 2014-02-27 07:52
  Compilé   : Fedora Project à 2014-02-18 07:24

$ yum --version
3.4.3
  Installés : rpm-4.11.2-2.fc20.x86_64 à 2014-02-27 07:52
  Compilé   : Fedora Project à 2014-02-18 07:24
  Commité   : Panu Matilainen <pmatilai@redhat.com> à 2014-02-18

  Installés : yum-3.4.3-148.fc20.noarch à 2014-06-16 12:41
  Compilé   : Fedora Project à 2014-05-22 09:50
  Commité   : James Antill <james at fedoraproject.org> à 2014-05-21

How reproducible:

Always !

Steps to Reproduce:
1. dnf update

Actual results:

Running transaction check
ERROR with transaction check vs depsolve:
Traceback (most recent call last):
  File "/bin/dnf", line 36, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 206, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 82, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 141, in _main
    ret = resolving(cli, base)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 169, in resolving
    return_code, resultmsgs = base.do_transaction()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 231, in do_transaction
    return_code, resultmsgs = super(BaseCli, self).do_transaction(display)
  File "/usr/lib/python2.7/site-packages/dnf/base.py", line 589, in do_transaction
    print(i18n.to_utf8(msg))
NameError: global name 'i18n' is not defined

Comment 1 Ales Kozumplik 2014-07-08 06:42:50 UTC

*** This bug has been marked as a duplicate of bug 1112704 ***


Note You need to log in before you can comment on or make changes to this bug.