Bug 1117148 - [RFE] Allow to query on External Tracker 'Status' Field
[RFE] Allow to query on External Tracker 'Status' Field
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Query/Bug List (Show other bugs)
4.4
Unspecified Unspecified
medium Severity medium (vote)
: ---
: ---
Assigned To: Matt Tyson
tools-bugs
: Improvement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-07-08 03:22 EDT by Itamar Heim
Modified: 2014-08-10 21:07 EDT (History)
5 users (show)

See Also:
Fixed In Version: 4.4.5023
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-10 21:07:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Itamar Heim 2014-07-08 03:22:46 EDT
External Trackers have a status column, but it can't be searched on.
this would allow searching on things like all Closed bugs, with a non-closed SFDC ticket.
Comment 1 Simon Green 2014-07-08 23:43:59 EDT
We're only adding a new field and some code to extension/ExternalBugs/ not the whole kitchen sink :)
Comment 6 Jason McDonald 2014-07-29 01:48:57 EDT
I made some suggestions on the related test case in gerrit. Perhaps the next step is to update the test case then retest.

Due to the odd way in which Bugzilla gets the status updates (via AJAX request when a user loads the bug more than ten minutes after the last update), this bug can be a bit tricky to test.
Comment 11 Simon Green 2014-07-30 19:05:05 EDT
(In reply to Shirley Zhou from comment #10)
> For example, if Bug A has 2 external tracker, one is closed, the other one
> is Open, then this bug A should not be searched.

This is not how searching works. If you don't want to return bugs that have one closed and one other value, the correct custom search is

'NOT' 'External Bug Status' 'equals to' 'Closed'

This is different to 'External Bug Status' 'is not equals to' 'Closed' when there are two different values for the search.

> But it should be listed when use "contains closed", that's the difference
> between "equal to" and "contains "

That is not correct. 'Equals to' matches the whole string, 'contains' matches part of string. 

> For the "does not contain the string closed", I think it is obvious that we
> should not get bugs which contains closed status external tracker. 

I disagree with this. The external tracker status field is no different to other fields (except flag types) in the way matches are done with multiple values.

  -- simon

Note You need to log in before you can comment on or make changes to this bug.