Bug 1117316 - wrong return code from a pipe in command substitution
Summary: wrong return code from a pipe in command substitution
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ksh
Version: 6.5
Hardware: Unspecified
OS: Linux
urgent
high
Target Milestone: rc
: ---
Assignee: Michal Hlavinka
QA Contact: Martin Kyral
URL:
Whiteboard:
Depends On:
Blocks: 825520 1132741 1135405
TreeView+ depends on / blocked
 
Reported: 2014-07-08 13:21 UTC by Marcel Kolaja
Modified: 2018-12-09 18:07 UTC (History)
5 users (show)

Fixed In Version: ksh-20120801-18.el6
Doc Type: Bug Fix
Doc Text:
Due to a regression, the exit code returned from a command substitution containing a pipe could be nonzero even when a command did not fail. A patch has been provided to fix this bug, and the exit code of a command substitution is now correct.
Clone Of:
: 1135405 (view as bug list)
Environment:
Last Closed: 2014-10-14 07:07:49 UTC
Target Upstream Version:


Attachments (Terms of Use)
reproducer (57 bytes, text/plain)
2014-07-08 13:28 UTC, Marcel Kolaja
no flags Details
patch to fix this (2.45 KB, patch)
2014-07-16 15:45 UTC, Michal Hlavinka
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1381 0 normal SHIPPED_LIVE ksh bug fix update 2014-10-14 01:28:24 UTC

Description Marcel Kolaja 2014-07-08 13:21:46 UTC
Description of problem:
One gets a return code from a pipe in command substitution when pipefail is not set as if it were set.

Version-Release number of selected component (if applicable):
ksh-20120801-10.el6_5.6.x86_64

How reproducible:
always

Steps to Reproduce:
1. run the reproducer (see attached)

Actual results:
2

Expected results:
0

Additional info:
N/A

Comment 1 Marcel Kolaja 2014-07-08 13:28:15 UTC
Created attachment 916378 [details]
reproducer

Comment 2 Marcel Kolaja 2014-07-08 13:33:30 UTC
ksh-20120801-10.el6_5.4.x86_64 works correctly, so it's a regression.

Comment 4 Marcel Kolaja 2014-07-08 13:49:26 UTC
The regression is caused by the fix of bug #825520.

Comment 7 Michal Hlavinka 2014-07-16 15:45:54 UTC
Created attachment 918457 [details]
patch to fix this

Comment 15 errata-xmlrpc 2014-10-14 07:07:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1381.html


Note You need to log in before you can comment on or make changes to this bug.